Bug 187886 - nv driver crashes on 3rd suspend/resume
nv driver crashes on 3rd suspend/resume
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nv (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-04 06:08 EDT by Simon Goodall
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-04 18:07:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log file from failed resume attempt (45.00 KB, text/plain)
2006-04-04 06:08 EDT, Simon Goodall
no flags Details
Output of dmesg after failed resume attempt (43.11 KB, text/plain)
2006-04-04 06:09 EDT, Simon Goodall
no flags Details
lspci output (after resume failure) (1.35 KB, text/plain)
2006-04-04 06:10 EDT, Simon Goodall
no flags Details

  None (edit)
Description Simon Goodall 2006-04-04 06:08:35 EDT
Description of problem:
My laptop (dell inspiron 8500) can suspend and resume fine twice, but X crashes
on a third resume. My display does not turn back on and my keyboard does not
respond (except to sysrq). I can however log in remotely where X is taking ~97%
cpu. I can kill X and try to restart it, but it is unable to find any devices.

Version-Release number of selected component (if applicable):
xorg-x11-drv-nv-1.0.1.5-3.1

How reproducible:
Always


Steps to Reproduce:
1. Suspend/Resume 3 times
2.
3.
  
Actual results:
Display stays off,  keyboard lights(e.g. pressing caps) do not work.

Expected results:
Display turns on and back to a fully working system

Additional info:
Comment 1 Simon Goodall 2006-04-04 06:08:35 EDT
Created attachment 127283 [details]
Xorg log file from failed resume attempt
Comment 2 Simon Goodall 2006-04-04 06:09:25 EDT
Created attachment 127284 [details]
Output of dmesg after failed resume attempt
Comment 3 Simon Goodall 2006-04-04 06:10:12 EDT
Created attachment 127285 [details]
lspci output (after resume failure)
Comment 4 Mike A. Harris 2006-05-19 01:21:17 EDT
The backtrace seems to show this is a bug in the nv driver.  Please file a
report in X.Org bugzilla, so that Nvidia can investigate the problem and
provide a fix in time for X.Org 7.1 if it hasn't already been fixed.

http://bugs.freedesktop.org in the xorg component

Paste the URL here, and we'll track it.

Thanks in advance.
Comment 5 Mike A. Harris 2006-06-07 05:44:17 EDT
ping
Comment 6 Simon Goodall 2006-06-08 10:55:43 EDT
I have been unable to reproduce this bug. Since reporting it I have been using
the nvidia rpms from livna.org.
Re-testing just now did not result in a crash. Presumably some of the other xorg
or kernel updates have fixed something.
Comment 7 Matěj Cepl 2007-04-04 18:07:13 EDT
OK, closing per reporter's information. Reporter, please, reopen if this bug is
still alive.

Note You need to log in before you can comment on or make changes to this bug.