Bug 187894 - yum update removes RUNNING kernel modules (dom0)
yum update removes RUNNING kernel modules (dom0)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-04 07:28 EDT by Robert Story
Modified: 2014-01-21 17:53 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-10 14:47:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Story 2006-04-04 07:28:08 EDT
Description of problem:
Running yum update removes RUNNING kernel modules (dom0). I had logged into my
dom0 and tried to nfs mount something. The session went something this:

server # mount devg:/site /mnt/site
mount: unknown filesystem type 'nfs'

server # modprobe nfs
FATAL: Could not load /lib/modules/2.6.15-1.2054_FC5xen0/modules.dep: No such
file or directory

server # uname -a
Linux server 2.6.15-1.2054_FC5xen0 #1 SMP Tue Mar 14 16:23:33 EST 2006 i686 i686
i386 GNU/Linux

server # depmod -a
WARNING: Couldn't open directory /lib/modules/2.6.15-1.2054_FC5xen0: No such
file or directory
FATAL: Could not open /lib/modules/2.6.15-1.2054_FC5xen0/modules.dep.temp for
writing: No such file or directory

checking my nightly update log, I see:

---> Package kernel.i686 0:2.6.15-1.2041_FC5 set to be erased
---> Package kernel-xen0.i686 0:2.6.15-1.2054_FC5 set to be erased
---> Package kernel-xenU.i686 0:2.6.15-1.2054_FC5 set to be erased


Version-Release number of selected component (if applicable):
yum-2.6.0-1 is what's there now (after a reboot; don't know if this is an
updated version since problem happened).

How reproducible:


Steps to Reproduce:
1. install/boot old dom0 kernel.
2. rpm -e latest dom0
3. yum update
  
Actual results:
Installing:
 kernel-xen0             i686       2.6.16-1.2080_FC5  updates-released   14 M
 kernel-xenU             i686       2.6.16-1.2080_FC5  updates-released  5.0 M
Removing:
 kernel-xen0             i686       2.6.15-1.2054_FC5  installed          39 M
 kernel-xenU             i686       2.6.15-1.2054_FC5  installed          13 M



Expected results:
Installing:
 kernel-xen0             i686       2.6.16-1.2080_FC5  updates-released   14 M
 kernel-xenU             i686       2.6.16-1.2080_FC5  updates-released  5.0 M


Additional info:
Comment 1 Jeremy Katz 2006-04-10 14:47:18 EDT
Fixed in CVS.  Fix will be in yum-2.6.0-2 in tomorrow's devel tree.  If you
could test it, that would be great.  This will eventually be pushed as an update
for FC5 (probably in a week or two -- want to coordinate with a yum 2.6.1 release)
Comment 2 Seth Vidal 2006-04-10 15:06:55 EDT
Is the bug happening in the plugin or somewhere in yum?
Comment 3 Jeremy Katz 2006-04-10 15:13:19 EDT
plugin -- dumb bug due to the last minute name change of the packages :(

Note You need to log in before you can comment on or make changes to this bug.