Bug 187908 - missing x86_64 build for this package
missing x86_64 build for this package
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-04 09:02 EDT by Kahlil Hodgson
Modified: 2014-01-21 17:53 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-04 18:31:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kahlil Hodgson 2006-04-04 09:02:16 EDT
Description of problem:

perl-Crypt-SSLeay does not seem to be built for x86_64 so if you 'yum install'
without watching you get the i386 installed which won't be found by perl.
(is this the right place to report this kind of thing?)

Version-Release number of selected component (if applicable):

perl-Crypt-SSLeay.i386                   0.51-9.2.2             core

How reproducible:

yum list perl-Crypt-SSLeay

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jason Vas Dias 2006-04-04 11:31:34 EDT
The x86_64 version definitely does exist and
supplies objects in the correct locations:

$ wget
'ftp://download.fedora.redhat.com/pub/fedora/linux/core/5/x86_64/os/Fedora/RPMS/perl-Crypt-SSLeay*'
...
$ rpm -qpl perl-Crypt-SSLeay-0.51-9.2.2.x86_64.rpm
/usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/Crypt
/usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/Crypt/SSLeay
/usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/Crypt/SSLeay.pm
/usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/Crypt/SSLeay/CTX.pm
/usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/Crypt/SSLeay/Conn.pm
/usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/Crypt/SSLeay/Err.pm
/usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/Crypt/SSLeay/MainContext.pm
/usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/Crypt/SSLeay/X509.pm
/usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/Net
/usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/Net/SSL.pm
/usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/auto/Crypt
/usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/auto/Crypt/SSLeay
/usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/auto/Crypt/SSLeay/SSLeay.so
/usr/share/doc/perl-Crypt-SSLeay-0.51
/usr/share/doc/perl-Crypt-SSLeay-0.51/CHANGES
/usr/share/man/man3/Crypt::SSLeay.3pm.gz

Strange that yum had decided to install the i386 version - this would 
appear to be a yum bug.

If the arch-specific version of a perl module package exists, (eg. x86_64)
yum must install that version on multilib architectures.

Please supply the following further information:

o Did you modify the default /etc/yum.conf or /etc/yum.repos.d/* files 
  in any way ? 
  If so, please append the files you modified to this bug report.
Comment 2 Seth Vidal 2006-04-04 11:59:44 EDT
why is it a yum bug? - if the i386 one is available it can be installed on an
x86_64 system.

Yum will install both, if the arch is unspecified.


I'd bet this system isn't as x86_64 as it seems.
Comment 4 Jason Vas Dias 2006-04-04 12:18:50 EDT
Please could the reporter also provide the following information:
 $ rpm -q perl --qf '%{ARCH}\n' 

If the above command emits 'i386', then this is NOTABUG and should be closed;
you'll need to install the perl-*.x86_64 rpms to get the x86_64 modules.

If it emits 'x86_64', it is a yum bug: yum should not install any i386 
perl modules when the perl-5.8.8-*.x86_64.rpm is installed.
Comment 5 Seth Vidal 2006-04-04 13:08:16 EDT
it's much easier to do:

yum list perl\*


as yum lists the arch by default.

Comment 6 Kahlil Hodgson 2006-04-04 18:31:22 EDT
Sorry guys,

It looks like this was some late night perl-hacker confusion:-(
My yum.repos.d/fedora-core.conf was looking at the wrong local mirror
and when I checked with http://fedoraproject.org/extras/5/x86_64/repodata/
I was looking at 'extras' and not 'core'.

Anyway, thanks for the very prompt response, and sincere apologies for the
false bug report.

Warm regards,

Kahlil Hodgson.

(In reply to comment #1)
> The x86_64 version definitely does exist and
> supplies objects in the correct locations:
> 
> $ wget
>
'ftp://download.fedora.redhat.com/pub/fedora/linux/core/5/x86_64/os/Fedora/RPMS/perl-Crypt-SSLeay*'
> ...
> $ rpm -qpl perl-Crypt-SSLeay-0.51-9.2.2.x86_64.rpm
> /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/Crypt
> /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/Crypt/SSLeay
> /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/Crypt/SSLeay.pm
> /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/Crypt/SSLeay/CTX.pm
> /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/Crypt/SSLeay/Conn.pm
> /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/Crypt/SSLeay/Err.pm
>
/usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/Crypt/SSLeay/MainContext.pm
> /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/Crypt/SSLeay/X509.pm
> /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/Net
> /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/Net/SSL.pm
> /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/auto/Crypt
> /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/auto/Crypt/SSLeay
>
/usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/auto/Crypt/SSLeay/SSLeay.so
> /usr/share/doc/perl-Crypt-SSLeay-0.51
> /usr/share/doc/perl-Crypt-SSLeay-0.51/CHANGES
> /usr/share/man/man3/Crypt::SSLeay.3pm.gz
> 
> Strange that yum had decided to install the i386 version - this would 
> appear to be a yum bug.
> 
> If the arch-specific version of a perl module package exists, (eg. x86_64)
> yum must install that version on multilib architectures.
> 
> Please supply the following further information:
> 
> o Did you modify the default /etc/yum.conf or /etc/yum.repos.d/* files 
>   in any way ? 
>   If so, please append the files you modified to this bug report.


Note You need to log in before you can comment on or make changes to this bug.