Bug 1879321 - Could not get mimetype, Error when getting information for file > 3.9 million lines in journal
Summary: Could not get mimetype, Error when getting information for file > 3.9 million...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: tracker-miners
Version: 33
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Kalev Lember
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-16 02:12 UTC by Heðin
Modified: 2020-09-17 11:51 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-17 08:20:57 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
GNOME Gitlab GNOME/tracker-miners - issues 136 0 None None None 2020-09-17 11:51:35 UTC

Description Heðin 2020-09-16 02:12:15 UTC
Description of problem:
millions of lines in journalctl -b

Version-Release number of selected component (if applicable):
F33 beta 1, patched as of filing this bz

How reproducible:
100%

Steps to Reproduce:
1. Install F33
2. Install CPU-X
3. run journalctl -b -f

Actual results:
journalctl is spammed with millions of lines

Expected results:
some throttling for the spam, maybe a few thousind lines ?

Additional info:
Bottom snippet from journalctl -b -q
        Sep 16 02:52:29 theWorkstation tracker-extract[3542]: Task for 'file:///usr/share/applications/cpu-x.desktop%3B5f608c72' finished with error: Error when getting information for file “/usr/share/applications/cpu-x.desktop;5f608c72”: No such file or directory
        Sep 16 02:52:29 theWorkstation tracker-extract[3542]: Could not get mimetype, Error when getting information for file “/usr/share/applications/cpu-x.desktop;5f608c72”: No such file or directory
        Sep 16 02:52:29 theWorkstation tracker-extract[3542]: Could not get mimetype: Error when getting information for file “/usr/share/applications/cpu-x.desktop;5f608c72”: No such file or directory
        Sep 16 02:52:29 theWorkstation tracker-extract[3542]: Task for 'file:///usr/share/applications/cpu-x.desktop%3B5f608c72' finished with error: Error when getting information for file “/usr/share/applications/cpu-x.desktop;5f608c72”: No such file or directory
        Sep 16 02:52:29 theWorkstation tracker-extract[3542]: Could not get mimetype, Error when getting information for file “/usr/share/applications/cpu-x.desktop;5f608c72”: No such file or directory
        Sep 16 02:52:29 theWorkstation tracker-extract[3542]: Could not get mimetype: Error when getting information for file “/usr/share/applications/cpu-x.desktop;5f608c72”: No such file or directory
        Sep 16 02:52:29 theWorkstation tracker-extract[3542]: Task for 'file:///usr/share/applications/cpu-x.desktop%3B5f608c72' finished with error: Error when getting information for file “/usr/share/applications/cpu-x.desktop;5f608c72”: No such file or directory
        Sep 16 02:52:29 theWorkstation tracker-extract[3542]: Could not get mimetype, Error when getting information for file “/usr/share/applications/cpu-x.desktop;5f608c72”: No such file or directory
        lines 3990341-3990414/3990414 (END)

Comment 1 Chris Murphy 2020-09-16 02:17:28 UTC
tracker-miners-2.3.5-1.fc33.x86_64
cpu-x-4.0.1-5.fc33.x86_64

Comment 2 Kalev Lember 2020-09-16 03:55:34 UTC
Can you try if installing https://kojipkgs.fedoraproject.org//packages/tracker3-miners/3.0.0/2.fc33/x86_64/tracker3-miners-3.0.0-2.fc33.x86_64.rpm helps? It has upstream https://gitlab.gnome.org/GNOME/tracker-miners/-/merge_requests/265 backported that is supposed to fix this issue.

Comment 3 Chris Murphy 2020-09-16 05:28:13 UTC
I have both and I'm not seeing the problem. In fact, I'm not seeing tracker-extract in the journal; and nothing tracker related reported by 'ps -aux'
tracker3-miners-3.0.0-1.fc33.x86_64
tracker-miners-2.3.5-1.fc33.x86_64

Heðin do you have both of these versions installed? It's only brought in recently so just 'dnf update' and you should get it.

Comment 4 Kalev Lember 2020-09-16 05:46:30 UTC
(In reply to Chris Murphy from comment #3)
> I have both and I'm not seeing the problem. In fact, I'm not seeing
> tracker-extract in the journal; and nothing tracker related reported by 'ps
> -aux'
> tracker3-miners-3.0.0-1.fc33.x86_64
> tracker-miners-2.3.5-1.fc33.x86_64
> 
> Heðin do you have both of these versions installed? It's only brought in
> recently so just 'dnf update' and you should get it.

No, this is incorrect. tracker3-miners-3.0.0-2.fc33 (note the -2) is the version that has a possible fix to the issue and it's _not_ available from the repos yet. If possible, please install it directly from the link above and see if it helps.

Comment 5 Heðin 2020-09-17 00:17:14 UTC
dnf history info tracker3-miners show that prior to installing 3.0.0-2, I had 2.99.5-1 installed, alongside the tracker-miners-2* package

Comment 6 Heðin 2020-09-17 08:08:53 UTC
(In reply to Kalev Lember from comment #4)
> (In reply to Chris Murphy from comment #3)
> > I have both and I'm not seeing the problem. In fact, I'm not seeing
> > tracker-extract in the journal; and nothing tracker related reported by 'ps
> > -aux'
> > tracker3-miners-3.0.0-1.fc33.x86_64
> > tracker-miners-2.3.5-1.fc33.x86_64
> > 
> > Heðin do you have both of these versions installed? It's only brought in
> > recently so just 'dnf update' and you should get it.
> 
> No, this is incorrect. tracker3-miners-3.0.0-2.fc33 (note the -2) is the
> version that has a possible fix to the issue and it's _not_ available from
> the repos yet. If possible, please install it directly from the link above
> and see if it helps.

I installed it yesterday, rebooted and started cpu-x.

Now, after 8 hours uptime, the journal is only 4519 lines. so it seems the issue is resolved.

Comment 7 Kalev Lember 2020-09-17 08:20:57 UTC
Excellent, thanks for testing! (The update is now in the repos as well.)


Note You need to log in before you can comment on or make changes to this bug.