Bug 187937 - iptraf is generating "stack smashing detected" and exits
iptraf is generating "stack smashing detected" and exits
Product: Fedora
Classification: Fedora
Component: iptraf (Show other bugs)
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Miroslav Lichvar
Depends On:
  Show dependency treegraph
Reported: 2006-04-04 14:20 EDT by Sorin Sbarnea
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-04-06 03:06:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Sorin Sbarnea 2006-04-04 14:20:34 EDT
Description of problem:
iptraf is generating "stack smashing detected" and exists

Version-Release number of selected component (if applicable):
Latest release on FC5

How reproducible:

Steps to Reproduce:
1. run iptraf
2. choose any option from the menu
Actual results:
program is terminated

Expected results:
should work

Additional info:
Comment 1 Miroslav Lichvar 2006-04-05 04:40:53 EDT
I can't reproduce it. Does it still crash when everything in /var/lib/iptraf is
Comment 2 Sorin Sbarnea 2006-04-05 06:05:55 EDT
It crashes even if /var/lib/iptraf is empty.

I've tested on two different instalaltions. Still both of them are upgrade from
FC4 using yum. If you need further information I'm happy to send you.

(iptraf version is 3.0.0)
Comment 3 Miroslav Lichvar 2006-04-05 08:55:10 EDT
Have you any network interface with name longer than 7 chars?
Comment 4 Sorin Sbarnea 2006-04-05 09:37:00 EDT
Yes, both computers have VPN conections that uses valid interface aliases of up
to 13 chars.

Still the phisical interfaces are using default names like: eth0, eth1, eth2,
Comment 5 Sorin Sbarnea 2006-04-05 09:37:50 EDT
I should mention that in FC4 there was the same configuration and it worked
without problems.
Comment 6 Sorin Sbarnea 2006-04-05 09:45:56 EDT
I confirm that renaming the interface name will solve the problem. I would
consider this as a temporary solution but the bug it's clear in iptraf and
should be solved.
Comment 7 Sorin Sbarnea 2006-04-05 09:56:09 EDT
With interfaces up to 7 chars it working but you can access the options dialog.
It will reject telling that only the first instance can access options. Even if
there is only one instance running.
Comment 8 Miroslav Lichvar 2006-04-05 11:32:28 EDT
Ok, thanks for the informations. There will be updated package soon.

The thing with options dialog, it is probably just a lock file in
/var/lock/iptraf, iptraf -f should fix that.
Comment 9 Fedora Update System 2006-04-05 16:14:21 EDT
iptraf-3.0.0-1.3.FC5 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 10 Sorin Sbarnea 2006-04-06 05:16:08 EDT
i confirm that the problem is gone after the newly released iptraf. Thanks.
Comment 11 Roy-Magne Mo 2006-06-23 19:29:53 EDT
According to the changelog, this was first included in 3.0.0-2, and 3.0.0-1 is
the one in FC5, can this be pushed out for FC5?

* Thu Apr 06 2006 Miroslav Lichvar <mlichvar@redhat.com> 3.0.0-2
- fix crash when parsing long network interface name (#187937)

I'm seeing stack smashing errors with 3.0.0-1, currently not reproduced with
3.0.0-4 (from rawhide) on FC5.

BTW: My longest interface name is 9 characters 
Comment 12 Miroslav Lichvar 2006-06-26 07:09:47 EDT
It has been pushed for fc5 already, see comment #9.
Comment 13 Roy-Magne Mo 2006-06-26 08:25:14 EDT
(In reply to comment #12)
> It has been pushed for fc5 already, see comment #9.

yes, I saw that - but I got those messages on the updated one too. The one
compiled from rawhide on FC5 did not crash that way.
Comment 14 Miroslav Lichvar 2006-06-26 09:21:25 EDT
Your original comment is about 3.0.0-1, this version doesn't contain the patch.
The patch in the devel version is exactly the same as in 3.0.0-1.3.FC5.

Are you sure you have the 3.0.0-1.3.FC5 version installed? Reopen the bug if is
the case.

Note You need to log in before you can comment on or make changes to this bug.