Bug 187938 - Updated from fc3 to fc5: After Boot 3c59x sometimes shows eth0 as dev6521
Updated from fc3 to fc5: After Boot 3c59x sometimes shows eth0 as dev6521
Status: CLOSED DUPLICATE of bug 187878
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-04 14:22 EDT by Christian Weiss
Modified: 2015-01-04 17:26 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-04 14:42:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Weiss 2006-04-04 14:22:53 EDT
Description of problem:
After updating fc3 to fc5 the order of my ethernet devices changed.
eth0 -> eth2
eth1 -> eth0
eth2 -> eth1

Used IRQs changed, too (/var/log/messages).
No NIC worked until I deleted the configuration and recreated them with
sysconfig-network-gui.

Now, after rebooting sometimes my 3c905C-TX/TX-M [Tornado] looks like this
(ONBOOT=no because it is the dev for DSL):
# ifconfig -a
dev6521   Link encap:Ethernet  HWaddr 00:04:76:A1:1D:45
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:19 Base address:0x4000

# rmmod 3c59x
# modprobe 3c59x
# ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:04:76:A1:1D:45
          inet6 addr: fe80::204:76ff:fea1:1d45/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:528 (528.0 b)
          Interrupt:19

# lspci|grep Ether
02:00.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 43)
02:01.0 Ethernet controller: 3Com Corporation 3c905C-TX/TX-M [Tornado] (rev 74)
02:06.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
RTL-8139/8139C/8139C+ (rev 10)

# cat /proc/interrupts|grep eth
 18:          0   IO-APIC-level  eth1
 19:          6   IO-APIC-level  eth0
 20:       1657   IO-APIC-level  eth2

# grep eth /etc/modprobe.conf
alias eth1 via-rhine
alias eth0 3c59x
alias eth2 8139too

--- fc3, working ---
Mar 26 15:35:25 beach kernel: eth0: RealTek RTL8139 at 0xa000,
00:10:dc:21:94:dd, IRQ 9
Mar 26 15:35:25 beach kernel: ACPI: PCI Interrupt Link [LNKB] enabled at IRQ 12
Mar 26 15:35:25 beach kernel: PCI: setting IRQ 12 as level-triggered
Mar 26 15:35:26 beach kernel: ACPI: PCI Interrupt 0000:02:01.0[A] -> Link [LNKB]
-> GSI 12 (level, low) -> IRQ 12
Mar 26 15:35:26 beach kernel: 3c59x: Donald Becker and others.
www.scyld.com/network/vortex.html
Mar 26 15:35:26 beach kernel: 0000:02:01.0: 3Com PCI 3c905C Tornado at 0x9400.
Vers LK1.1.19
Mar 26 15:35:26 beach kernel: via-rhine.c:v1.10-LK1.2.0-2.6 June-10-2004 Written
by Donald Becker
Mar 26 15:35:26 beach kernel: ACPI: PCI Interrupt Link [LNKA] enabled at IRQ 5
Mar 26 15:35:26 beach kernel: PCI: setting IRQ 5 as level-triggered
Mar 26 15:35:26 beach kernel: ACPI: PCI Interrupt 0000:02:00.0[A] -> Link [LNKA]
-> GSI 5 (level, low) -> IRQ 5
Mar 26 15:35:26 beach kernel: eth2: VIA Rhine II at 0xeb000000,
00:50:ba:fb:21:c9, IRQ 5.
--- fc3, working ---

--- fc5, *not* working ---
Apr  2 16:31:51 beach kernel: via-rhine.c:v1.10-LK1.2.0-2.6 June-10-2004 Written
by Donald Becker
Apr  2 16:31:51 beach kernel: ACPI: PCI Interrupt 0000:02:00.0[A] -> GSI 16
(level, low) -> IRQ 16
Apr  2 16:31:51 beach kernel: PCI: Via IRQ fixup for 0000:02:00.0, from 5 to 0
Apr  2 16:31:51 beach kernel: eth0: VIA Rhine II at 0xeb000000,
00:50:ba:fb:21:c9, IRQ 16.
Apr  2 16:31:51 beach kernel: eth0: MII PHY found at address 8, status 0x7809
advertising 01e1 Link 0000.
Apr  2 16:31:51 beach kernel: ACPI: PCI Interrupt 0000:02:01.0[A] -> GSI 17
(level, low) -> IRQ 17
Apr  2 16:31:51 beach kernel: 3c59x: Donald Becker and others.
www.scyld.com/network/vortex.html
Apr  2 16:31:51 beach kernel: 0000:02:01.0: 3Com PCI 3c905C Tornado at d082e000.
Vers LK1.1.19
Apr  2 16:31:51 beach kernel: 8139cp: 10/100 PCI Ethernet driver v1.2 (Mar 22, 2004)
Apr  2 16:31:52 beach kernel: 8139cp: pci dev 0000:02:06.0 (id 10ec:8139 rev 10)
is not an 8139C+ compatible chip
Apr  2 16:31:52 beach kernel: 8139cp: Try the "8139too" driver instead.
Apr  2 16:31:52 beach kernel: 8139too Fast Ethernet driver 0.9.27
Apr  2 16:31:52 beach kernel: ACPI: PCI Interrupt 0000:02:06.0[A] -> GSI 21
(level, low) -> IRQ 20
Apr  2 16:31:52 beach kernel: eth2: RealTek RTL8139 at 0xd08bc000,
00:10:dc:21:94:dd, IRQ 20
Apr  2 16:31:52 beach kernel: ACPI: PCI Interrupt 0000:02:02.0[A] -> GSI 18
(level, low) -> IRQ 21
Apr  2 16:31:52 beach kernel: PCI: Via IRQ fixup for 0000:02:02.0, from 11 to 5
Apr  2 16:31:52 beach kernel: ohci1394: fw-host0: OHCI-1394 1.0 (PCI): IRQ=[21]
 MMIO=[eb002000-eb0027ff]  Max Packet=[2048]  IR/IT contexts=[8/8]
Apr  2 16:31:52 beach kernel: ACPI: PCI Interrupt 0000:02:07.0[A] -> GSI 20
(level, low) -> IRQ 22
--- fc5, *not* working ---

Problems with ACPI and IRQs reminds me of bug:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=167534

Version-Release number of selected component (if applicable):
kernel-2.6.16-1.2080_FC5

How reproducible:
Update fc3 with latest patches to fc5 (latest patches).

Actual results:
eth0 is sometims not working after reboot. eth0 is named dev6521 in ifconfig.

Expected results:
eth0 is eth0 is eth0

Additional info:
Could it be an ACPI issue?
Comment 1 Dave Jones 2006-04-04 14:42:38 EDT

*** This bug has been marked as a duplicate of 187878 ***

Note You need to log in before you can comment on or make changes to this bug.