Bug 187939 - openoffice doesn't fully recognise printers added since program invocation
openoffice doesn't fully recognise printers added since program invocation
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-04 14:24 EDT by Matthew Truch
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 2.0.2-5.9.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-03 03:23:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Truch 2006-04-04 14:24:58 EDT
Description of problem:
When running an openoffice.org componant and a printer is added (automagically
via cups detecting a new network printer for example), it is immediatly
available in the printer selection part of the print... menu, however, when you
actually try and print, it will send it to the default printer that was
available when openoffice was started, not the selected printer (that came
available since openoffice was started).  

Version-Release number of selected component (if applicable):
openoffice.org-core-2.0.2-5.2.2

How reproducible: Always

Steps to Reproduce:
1. Start openoffice (writer, impress, calc, whatever makes you happy)
2. Make a new printer available.  The easiest way is to have the network
unplugged/off before starting openoffice and then connecting so that network
printers will become available.
3. Go to File -> Print.
4. Choose one of the newly available printers; click on any requested options;
and print.
  
Actual results:
The print job is sent to the default printer that was available before
openoffice was started.

Expected results:
The print job is sent to the printer selected in step 4 above.
Comment 1 Caolan McNamara 2006-04-05 03:35:14 EDT
So this is not issue 187528 ?
Does it happen with gedit or any other application ?, 
What does rpm -q cups say ?
Did this always happen, or start happening recently ?
Comment 2 Matthew Truch 2006-04-05 12:18:15 EDT
(In reply to comment #1)
> So this is not issue 187528?

No, I don't think so.

> Does it happen with gedit or any other application ?

I haven't tested *all* applications, but it doesn't happen with gedit.  

> What does rpm -q cups say?

[matt@tbc ~]$ rpm -q cups
cups-1.1.23-30.2

> Did this always happen, or start happening recently ?

I *think* that it has always happened, but at first I was either in a hurry so
once I did get it to print I didn't look into it more, or I mistook the problem
for a fully improperly configured printer.  Yesterday is the first time that I
had a careful look at it.  
Comment 3 Caolan McNamara 2006-04-11 08:27:03 EDT
I think I see the problem, a bit tricky but I reckon we can resolve this
Comment 4 Caolan McNamara 2006-05-03 03:23:21 EDT
printer lists in sync over lifetime of office now
Comment 5 Matthew Truch 2006-05-06 12:18:25 EDT
I just got a chance to check this out.  Thanks for the fix.  

Note You need to log in before you can comment on or make changes to this bug.