Bug 1879427 - "floppy" and "edd" modules will try to load when installing kvm guest on aarch64 using cdrom
Summary: "floppy" and "edd" modules will try to load when installing kvm guest on aarc...
Keywords:
Status: CLOSED DUPLICATE of bug 1650261
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: anaconda
Version: 8.3
Hardware: aarch64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-16 09:39 UTC by Yihuang Yu
Modified: 2020-11-14 09:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-22 08:54:31 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
guest serial output (89.99 KB, text/plain)
2020-09-16 09:39 UTC, Yihuang Yu
no flags Details

Description Yihuang Yu 2020-09-16 09:39:54 UTC
Created attachment 1715042 [details]
guest serial output

Description of problem:
I tried to install RHEL-8.3.0 kvm guest using cdrom on aarch64. There are 3 modules "floppy", "edd" and "iscsi_ibft" failed to load at the installation stage. "iscsi_ibft" module can be tracked by bug 1790898.
This does not affect the guest installation, I can successfully install it.
In addition, these 3 modules cannot be found in ppc64le, but the installer will not have this problem. So I guess these modules should not try to load on aarch64.

Version-Release number of selected component (if applicable):
RHEL-8.3.0-20200909.1
kernel-4.18.0-235.el8.aarch64

How reproducible:
awlays

Steps to Reproduce:
1. Launch a guest 
MALLOC_PERTURB_=1  /usr/libexec/qemu-kvm \
    -S  \
    -name 'avocado-vt-vm1'  \
    -sandbox on  \
    -drive file=/usr/share/AAVMF/AAVMF_CODE.fd,if=pflash,format=raw,unit=0,readonly=on \
    -drive file=/var/lib/avocado/data/avocado-vt/images/rhel830-aarch64-virtio_AAVMF_VARS.fd,if=pflash,format=raw,unit=1 \
    -machine virt,gic-version=host \
    -device pcie-root-port,id=pcie-root-port-0,multifunction=on,bus=pcie.0,addr=0x1,chassis=1 \
    -device pcie-pci-bridge,id=pcie-pci-bridge-0,addr=0x0,bus=pcie-root-port-0  \
    -nodefaults \
    -device pcie-root-port,id=pcie-root-port-1,port=0x1,addr=0x1.0x1,bus=pcie.0,chassis=2 \
    -device virtio-gpu-pci,bus=pcie-root-port-1,addr=0x0 \
    -m 43008  \
    -smp 22,maxcpus=22,cores=11,threads=1,sockets=2  \
    -cpu 'host' \
    -chardev socket,path=/var/tmp/avocado_28g9vpxw/monitor-qmpmonitor1-20200910-232608-lqAakMfu,id=qmp_id_qmpmonitor1,server,nowait  \
    -mon chardev=qmp_id_qmpmonitor1,mode=control \
    -chardev socket,path=/var/tmp/avocado_28g9vpxw/monitor-catch_monitor-20200910-232608-lqAakMfu,id=qmp_id_catch_monitor,server,nowait  \
    -mon chardev=qmp_id_catch_monitor,mode=control  \
    -serial unix:'/var/tmp/avocado_28g9vpxw/serial-serial0-20200910-232608-lqAakMfu',server,nowait \
    -device pcie-root-port,id=pcie-root-port-2,port=0x2,addr=0x1.0x2,bus=pcie.0,chassis=3 \
    -device qemu-xhci,id=usb1,bus=pcie-root-port-2,addr=0x0 \
    -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1 \
    -blockdev node-name=file_image1,driver=file,aio=threads,filename=/home/kvm_autotest_root/images/rhel830-aarch64-virtio.qcow2,cache.direct=off,cache.no-flush=on \
    -blockdev node-name=drive_image1,driver=qcow2,cache.direct=off,cache.no-flush=on,file=file_image1 \
    -device pcie-root-port,id=pcie-root-port-3,port=0x3,addr=0x1.0x3,bus=pcie.0,chassis=4 \
    -device virtio-blk-pci,id=image1,drive=drive_image1,bootindex=1,write-cache=on,bus=pcie-root-port-3,addr=0x0 \
    -device pcie-root-port,id=pcie-root-port-4,port=0x4,addr=0x1.0x4,bus=pcie.0,chassis=5 \
    -device virtio-net-pci,mac=9a:4d:c5:9e:51:12,rombar=0,id=idKuDaEj,netdev=ideQYgGZ,bus=pcie-root-port-4,addr=0x0  \
    -netdev tap,id=ideQYgGZ,vhost=on,vhostfd=21,fd=14 \
    -device pcie-root-port,id=pcie-root-port-5,port=0x5,addr=0x1.0x5,bus=pcie.0,chassis=6 \
    -device virtio-scsi-pci,id=virtio_scsi_pci0,bus=pcie-root-port-5,addr=0x0 \
    -blockdev node-name=file_unattended,driver=file,read-only=on,aio=threads,filename=/home/kvm_autotest_root/images/rhel830-aarch64/ks.iso,cache.direct=off,cache.no-flush=on \
    -blockdev node-name=drive_unattended,driver=raw,read-only=on,cache.direct=off,cache.no-flush=on,file=file_unattended \
    -device scsi-cd,id=unattended,drive=drive_unattended,bootindex=3,write-cache=on  \
    -kernel '/home/kvm_autotest_root/images/rhel830-aarch64/vmlinuz'  \
    -append 'inst.sshd ksdevice=link inst.ks=cdrom:/dev/sr0:/ks.cfg nicdelay=60 biosdevname=0 net.ifnames=0 console=ttyAMA0 inst.repo=http://download.eng.bos.redhat.com/rhel-8/rel-eng/RHEL-8/latest-RHEL-8.3.0/compose/BaseOS/aarch64/os/'  \
    -initrd '/home/kvm_autotest_root/images/rhel830-aarch64/initrd.img'  \
    -vnc :0  \
    -rtc base=utc,clock=host  \
    -no-shutdown \
    -enable-kvm \
    -device pcie-root-port,id=pcie_extra_root_port_0,multifunction=on,bus=pcie.0,addr=0x2,chassis=7 \
    -device pcie-root-port,id=pcie_extra_root_port_1,addr=0x2.0x1,bus=pcie.0,chassis=8

2. Install the guest and check serial output
2020-09-10 23:26:27: [   10.041572] dracut-pre-udev[716]: modprobe: FATAL: Module floppy not found in directory /lib/modules/4.18.0-235.el8.aarch64
2020-09-10 23:26:27: [   10.049555] dracut-pre-udev[716]: modprobe: FATAL: Module edd not found in directory /lib/modules/4.18.0-235.el8.aarch64
2020-09-10 23:26:28: [   10.058030] dracut-pre-udev[716]: modprobe: FATAL: Module iscsi_ibft not found in directory /lib/modules/4.18.0-235.el8.aarch64
...
...
2020-09-10 23:26:58: [7m[anaconda]1:main* 2:shell  3:log  4:sto><'echo -n "Switch tab: Alt+Tab | Help: F[m(B[1;1H[24;1H[7m[anaconda]1:main* 2:shell  3:log  4:storage-log >Switch tab: Alt+Tab | Help: F1 [m(B[1;1HStarting installer, one moment...
2020-09-10 23:27:01: anaconda 33.16.3.24-1.el8 for Red Hat Enterprise Linux 8.3 (pre-release) started.
2020-09-10 23:27:01:  * installation log files are stored in /tmp during the installation
2020-09-10 23:27:01:  * shell is available on TTY2
2020-09-10 23:27:01:  * when reporting a bug add logs from /tmp as separate text/plain attachments
2020-09-10 23:27:14: Warning:          Could not resolve keysym XF86MonBrightnessCycle
2020-09-10 23:27:14: Warning:          Could not resolve keysym XF86RotationLockToggle
2020-09-10 23:36:12: OS install is completed

3.

Actual results:
2020-09-10 23:26:27: [   10.041572] dracut-pre-udev[716]: modprobe: FATAL: Module floppy not found in directory /lib/modules/4.18.0-235.el8.aarch64
2020-09-10 23:26:27: [   10.049555] dracut-pre-udev[716]: modprobe: FATAL: Module edd not found in directory /lib/modules/4.18.0-235.el8.aarch64
2020-09-10 23:26:28: [   10.058030] dracut-pre-udev[716]: modprobe: FATAL: Module iscsi_ibft not found in directory /lib/modules/4.18.0-235.el8.aarch64

Expected results:
"modprobe: FATAL" messages should not be reported.

Additional info:
I am not sure if the component I selected is right, please help to correct it if I am wrong.

Drivers on different architectures:
x86:
ls /lib/modules/4.18.0-235.el8.x86_64/kernel/drivers/firmware/
dcdbas.ko.xz  dell_rbu.ko.xz  edd.ko.xz  iscsi_ibft.ko.xz

ppc64le:
# ls /lib/modules/4.18.0-236.el8.ppc64le/kernel/drivers/firewire/
firewire-core.ko.xz  firewire-net.ko.xz  firewire-ohci.ko.xz  firewire-sbp2.ko.xz

aarch64:
# ls /lib/modules/4.18.0-235.el8.aarch64/kernel/drivers/firmware/
arm_scpi.ko.xz  scpi_pm_domain.ko.xz

Comment 1 Jiri Konecny 2020-09-22 08:54:31 UTC
This issue is already solved by:

https://github.com/rhinstaller/anaconda/pull/2653


And already filed. Closing as duplicate. Feel free to re-open this bug if you don't agree with solution to suppress this messages.

*** This bug has been marked as a duplicate of bug 1650261 ***


Note You need to log in before you can comment on or make changes to this bug.