Bug 187944 - Internal compiler error
Summary: Internal compiler error
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: gcc   
(Show other bugs)
Version: 4.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-04-04 19:47 UTC by Eric Coulthard
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version: 3.4.5-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-06 09:35:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File which caused g++ to get an internal compiler error (180 bytes, application/octet-stream)
2006-04-04 19:47 UTC, Eric Coulthard
no flags Details

Description Eric Coulthard 2006-04-04 19:47:25 UTC
Description of problem:

Internal Compiler Error in g++

Version-Release number of selected component (if applicable):

g++ -v
Reading specs from /usr/lib/gcc/i386-redhat-linux/3.4.4/specs
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man
--infodir=/usr/share/info --enable-shared --enable-threads=posix
--disable-checking --with-system-zlib --enable-__cxa_atexit
--disable-libunwind-exceptions --enable-java-awt=gtk --host=i386-redhat-linux
Thread model: posix
gcc version 3.4.4 20050721 (Red Hat 3.4.4-2)


How reproducible:


Steps to Reproduce:
1. compile the attached file test.cpp using the command
g++ test.cpp
  
Actual results:

g++ test.cpp        
test.cpp: In constructor `A::A()':
test.cpp:11: internal compiler error: in lookup_member, at cp/search.c:1287
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
Preprocessed source stored into /tmp/ccIRqz2h.out file, please attach this to
your bugreport.

Expected results:

It should report an error for trying to call the constructor for member
vector<string> aVector inside the constructor for object A.

Additional info:

test.cpp is attached
You can generate the preprocessed source by trying to compile it.

Comment 1 Eric Coulthard 2006-04-04 19:47:25 UTC
Created attachment 127309 [details]
File which caused g++ to get an internal compiler error

Comment 2 Jakub Jelinek 2006-04-06 09:35:10 UTC
Works for me with current RHEL4 errata GCC:

rpm -q gcc-c++; g++ -v; g++ -S 187944.C
gcc-c++-3.4.5-2
Reading specs from /usr/lib/gcc/i386-redhat-linux/3.4.5/specs
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man
--infodir=/usr/share/info --enable-shared --enable-threads=posix
--disable-checking --with-system-zlib --enable-__cxa_atexit
--disable-libunwind-exceptions --enable-java-awt=gtk --host=i386-redhat-linux
Thread model: posix
gcc version 3.4.5 20051201 (Red Hat 3.4.5-2)
187944.C: In constructor `A::A()':
187944.C:11: error: invalid use of `class std::vector<std::string,
std::allocator<std::string> >'



Note You need to log in before you can comment on or make changes to this bug.