This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 187946 - CVE-2006-0670 bluez-hcidump Denial of Service
CVE-2006-0670 bluez-hcidump Denial of Service
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: bluez-hcidump (Show other bugs)
5
All Linux
medium Severity low
: ---
: ---
Assigned To: David Woodhouse
source=vulnwatch,public=20060205,repo...
: Security
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-04 16:01 EDT by Josh Bressers
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-21 05:49:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Josh Bressers 2006-04-04 16:01:29 EDT
bluez-hcidump Denial of Service

http://www.secuobs.com/news/05022006-bluetooth10.shtml

"ubuntu: Pierre Betouin discovered a Denial of Service
vulnerability in the handling of the L2CAP (Logical Link
Control and Adaptation Layer Protocol) layer. By sending a
specially crafted L2CAP packet through a wireless Bluetooth
connection, a remote attacker could crash hcidump.  Since
hcidump is mainly a debugging tool, the impact of this flaw is
very low."

The patch is here:
http://cvs.sourceforge.net/viewcvs.py/bluez/hcidump/parser/l2cap.c?r1=1.51&r2=1.52&diff_format=u


This issue also affects FC4

Note You need to log in before you can comment on or make changes to this bug.