Bug 187963 - FC5 dmraid issue in /etc/rc.sysinit script
FC5 dmraid issue in /etc/rc.sysinit script
Status: CLOSED DUPLICATE of bug 183959
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-04 18:11 EDT by Max Pyziur
Modified: 2014-03-16 22:59 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-26 12:21:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Max Pyziur 2006-04-04 18:11:05 EDT
+++ This bug was initially created as a clone of Bug #187962 +++

Description of problem:
When booting up the
/etc/rc.d/rc.sysinit script reports the following error:
ERROR: No arguments allowed with -i

ERROR: No arguments allowed with -i

ERROR: No arguments allowed with -i



Version-Release number of selected component (if applicable):
initscripts-8.31.1-1
dmraid-1.0.0.rc9-FC5_5.2
How reproducible:


Steps to Reproduce:
1. Boot the machine; you'll see the error just before the init.d scripts start
running.  My machine is: PIII-1400MHZ, 1GB RAM, 40GB HDD as /dev/hda and 120GB
HDD as /dev/hdb. The machine is setup not to run RAID.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Ed 2006-04-26 01:53:44 EDT
I noticed this also and added echo statements to rc.sysinit to try and narrow it
down. The error message is generated by the following call (line 266 on my system):

                        if [ -z "$dmname" ]; then
                                /sbin/dmraid -ay --ignorelocking "$x"
                        fi
Comment 2 Milan Broz 2006-04-26 02:55:07 EDT
The problem is related to -i parameter in dmraid - see bug 183959.
Comment 3 Bill Nottingham 2006-04-26 12:21:21 EDT

*** This bug has been marked as a duplicate of 183959 ***

Note You need to log in before you can comment on or make changes to this bug.