Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1879779 - oVirt Node Next 4.4 is unusable on many still popular hardware.
Summary: oVirt Node Next 4.4 is unusable on many still popular hardware.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: ovirt-node
Classification: oVirt
Component: Installation & Update
Version: 4.4.0
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: ---
Assignee: Nir Levy
QA Contact: Yaning Wang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-17 00:10 UTC by Szymon Madej
Modified: 2020-11-14 04:52 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-17 07:33:34 UTC
oVirt Team: Node


Attachments (Terms of Use)
Screenshot from installer of oVirt Node Next 4.4 and Fedora Server 32 on my hardware. (250.55 KB, application/zip)
2020-09-17 00:10 UTC, Szymon Madej
no flags Details

Description Szymon Madej 2020-09-17 00:10:45 UTC
Created attachment 1715147 [details]
Screenshot from installer of oVirt Node Next 4.4 and Fedora Server 32 on my hardware.

Description of problem:

Upgrading base system from CentOS 7 in oVirt 4.3 to CentOS 8 in oVirt 4.4 made it unusable on vast spectrum of hardware. This is because Red Hat decided to castrate kernel in RHEL 8 from many drivers for still popular hardware. This is described here https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/8/html-single/considerations_in_adopting_rhel_8/index#removed-adapters_hardware-enablement 
This was quickly noticed by Community. I've tracked earliest mentions about problems generated by this interference in RHEL 8 kernel to June 2019 at https://access.redhat.com/discussions/3722151
Sadly nothing changed since then :-(

I'm currently using many of still young (4-5 years old) IBM Flex System x240 with 2x6 core CPUs (24 threads), 180GB of RAM, 10Gb network, 16Gb FC in each such blade server. Plenty of resources that I cannot populate with RHEL/OEL/CentOS 8.x and now also with latest oVirt Node Next 4.4.x


Version-Release number of selected component (if applicable): oVirt Node 4.4.0 and above.

How reproducible: Every time.


Steps to Reproduce:
1. Try to install oVirt Node Next 4.4.x on i.e. IBM Flex System x240 or other similar server.

Actual results:
1. There is no local disk visible. In oVirt Node 4.3.x installer, I see RAID1 local disk here, build on MPT LSI controller from two disks installed in this server.
2. There is no network cards visible. In oVirt Node 4.3.x installer, I see 16 network cards here (2-port mezzanine card * 2 switches in blade chassis * 4 Virtual VLAN interfaces on such channel)

Expected results:
Visibility of the same hardware as in oVirt Node 4.3.x installler. 

Additional info:
Is there an oVirt Node Next 4.4.x ISO image build on Fedora Server instead of CentOS 8?
Is it possible to use an alternate kernel (i.e. from ELRepo el8 kernel repository) in oVirt Node Next 4.4.x which is build on CentOS 8?

In both these kernels (ElRepo's builds and provided by Fedora Server) drivers cut by Red Hat in RHEL 8 still exists i.e.:

# cat /etc/redhat-release
Fedora release 30 (Thirty)
# find /lib/modules -name "*be2net*"
/lib/modules/5.0.9-301.fc30.x86_64/kernel/drivers/net/ethernet/emulex/benet/be2net.ko.xz
/lib/modules/5.1.18-300.fc30.x86_64/kernel/drivers/net/ethernet/emulex/benet/be2net.ko.xz
/lib/modules/5.2.16-200.fc30.x86_64/kernel/drivers/net/ethernet/emulex/benet/be2net.ko.xz
# find /lib/modules -name "*mpt3sas*"
/lib/modules/5.0.9-301.fc30.x86_64/kernel/drivers/scsi/mpt3sas
/lib/modules/5.0.9-301.fc30.x86_64/kernel/drivers/scsi/mpt3sas/mpt3sas.ko.xz
/lib/modules/5.1.18-300.fc30.x86_64/kernel/drivers/scsi/mpt3sas
/lib/modules/5.1.18-300.fc30.x86_64/kernel/drivers/scsi/mpt3sas/mpt3sas.ko.xz
/lib/modules/5.2.16-200.fc30.x86_64/kernel/drivers/scsi/mpt3sas
/lib/modules/5.2.16-200.fc30.x86_64/kernel/drivers/scsi/mpt3sas/mpt3sas.ko.xz
#

I've checked up to the latest Fedora Server 32 installer (view attachments) and can confirm that it works on my hardware.

Comment 1 Sandro Bonazzola 2020-09-17 07:33:34 UTC
If you need alternate kernel, please use CentOS instead of oVirt Node.
Please note alternate kernels are not tested by oVirt developers.


Note You need to log in before you can comment on or make changes to this bug.