Bug 187988 - Authorisation using winbind helpers failure
Authorisation using winbind helpers failure
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: squid (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-05 01:50 EDT by Need Real Name
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-05 03:50:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2006-04-05 01:50:38 EDT
Description of problem:
Authorisation using winbind failure. Using wb_auth and wb_ntlmauth helpers it
appears error "Can't contact winbindd. Dying."

Version-Release number of selected component (if applicable):
squid-2.5.STABLE13 (the same at previous versions)

How reproducible:
Simply call wb_auth or wb_ntlmauth(other helpers not checked)

Steps to Reproduce:
1. 
2.
3.
  
Actual results:
Error message from helpers: "Can't contact winbindd. Dying."

Expected results:

Additional info:
In squid-2.5.STABLE5-pipe.patch there is string:
#define WINBINDD_SOCKET_DIR  "/var/run/winbindd/pipe"
But it shows not dir, but pipe itself.
In wb_common.c in function winbind_open_pipe_sock() there is check:
lstat(WINBINDD_SOCKET_DIR)... if(!S_ISDIR... 
Debugging shows, that because it is not dir, it failures.

After changing to:
#define WINBINDD_SOCKET_DIR  "/var/run/winbindd"
helpers can connect to winbind socket.

Note You need to log in before you can comment on or make changes to this bug.