Bug 187993 - TBfea3ebb1 miscutils.py:61:checkSig:OSError: [Errno 2] No such file or directory: '//var/cache/yum/extras/packages/pam_usb-0.3.3-4.fc5.x86_64.rpm
TBfea3ebb1 miscutils.py:61:checkSig:OSError: [Errno 2] No such file or direct...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
5
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-05 04:08 EDT by Jaros Warner
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-18 09:50:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaros Warner 2006-04-05 04:08:57 EDT
Description of problem:
Component: yumex
Version: 0.99.15
Summary: TBfea3ebb1 miscutils.py:61:checkSig:OSError: [Errno 2] No such file or
directory: '//var/cache/yum/extras/packages/pam_usb-0.3.3-4.fc5.x86_64.rpm'

Traceback (most recent call last):
  File "/usr/share/yumex/yumexmain.py", line 127, in on_queueProcess_clicked
    if self.action.process_package_queue( pkgs, doAll):
  File "/usr/lib/python2.4/site-packages/yumex/yumexBase.py", line 1015, in
process_package_queue
    if not self.process_packages():
  File "/usr/lib/python2.4/site-packages/yumex/yumexBase.py", line 1210, in
process_packages
    if not self.yumexbase.process_transaction():
  File "/usr/lib/python2.4/site-packages/yumex/yumexBase.py", line 608, in
process_transaction
    self.download_packages()
  File "/usr/lib/python2.4/site-packages/yumex/yumexBase.py", line 655, in
download_packages
    self.gpgsigcheck( downloadpkgs )
  File "/usr/lib/python2.4/site-packages/yumex/yumexBase.py", line 763, in
gpgsigcheck
    result, errmsg = self.sigCheckPkg( po )
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 770, in sigCheckPkg
    sigresult = rpmUtils.miscutils.checkSig(self.read_ts, po.localPkg())
  File "/usr/lib/python2.4/site-packages/rpmUtils/miscutils.py", line 61, in
checkSig
    fdno = os.open(package, os.O_RDONLY)
OSError: [Errno 2] No such file or directory:
'//var/cache/yum/extras/packages/pam_usb-0.3.3-4.fc5.x86_64.rpm'

Local variables in innermost frame:
currentflags: 986880
ts: <rpmUtils.transaction.TransactionWrapper instance at 0x2aaaaae07b48>
value: 0
package: //var/cache/yum/extras/packages/pam_usb-0.3.3-4.fc5.x86_64.rpm

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tim Lauridsen 2006-04-06 01:58:03 EDT
I looks like a package was not downloaded correctly into the yum cache directory
and the GPG check fails because the package is missing. I will look into this
issue, but it can de hard to reproduce the error
Comment 2 Tim Lauridsen 2006-04-18 09:50:35 EDT
it is somekind of error in yum, i cant fix that, but i have made a fix so yumex
don't crach but reports an error dialog with the error.

Note You need to log in before you can comment on or make changes to this bug.