Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1879983 - [v2v][VM import from RHV to CNV] VM import of a rhel7 VM with preallocated disk fail on DV creation [NEEDINFO]
Summary: [v2v][VM import from RHV to CNV] VM import of a rhel7 VM with preallocated di...
Keywords:
Status: CLOSED INSUFFICIENT_DATA
Alias: None
Product: Container Native Virtualization (CNV)
Classification: Red Hat
Component: V2V
Version: 2.4.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 2.5.0
Assignee: Piotr Kliczewski
QA Contact: Ilanit Stein
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-17 14:02 UTC by Ilanit Stein
Modified: 2020-10-13 11:43 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-13 11:43:47 UTC
Target Upstream Version:
pkliczew: needinfo? (istein)


Attachments (Terms of Use)
vm-import-controller.log (2.20 MB, text/plain)
2020-09-17 14:02 UTC, Ilanit Stein
no flags Details
rhv7-vm-xml.txt (6.82 KB, text/plain)
2020-09-21 05:36 UTC, Ilanit Stein
no flags Details

Description Ilanit Stein 2020-09-17 14:02:07 UTC
Created attachment 1715233 [details]
vm-import-controller.log

Description of problem:
When trying in automation to run VM import for a rhel7 VM with praallocated disk the VM import failed with VM creation error.
The image copy or  pvc/pv creation was not done.

VM import controller log showed this error:
{"level":"error","ts":1600296824.8010805,"logger":"controller-runtime.controller","msg":"Reconciler error","controller":"virtualmachineimport-controller","request":"default/vm-import-v2v-rhel7-vm-f628l","error":"ovirt client panicked: runtime error: invalid memory address or nil pointer dereference","stacktrace":"github.com/go-logr/zapr.(*zapLogger).Error\n\t/go/src/github.com/kubevirt/vm-import-operator/vendor/github.com/go-logr/zapr/zapr.go:128\nsigs.k8s.io/controller-runtime/pkg/internal/controller.(*Controller).reconcileHandler\n\t/go/src/github.com/kubevirt/vm-import-operator/vendor/sigs.k8s.io/controller-runtime/pkg/internal/controller/controller.go:258\nsigs.k8s.io/controller-runtime/pkg/internal/controller.(*Controller).processNextWorkItem\n\t/go/src/github.com/kubevirt/vm-import-operator/vendor/sigs.k8s.io/controller-runtime/pkg/internal/controller/controller.go:232\nsigs.k8s.io/controller-runtime/pkg/internal/controller.(*Controller).worker\n\t/go/src/github.com/kubevirt/vm-import-operator/vendor/sigs.k8s.io/controller-runtime/pkg/internal/controller/controller.go:211\nk8s.io/apimachinery/pkg/util/wait.JitterUntil.func1\n\t/go/src/github.com/kubevirt/vm-import-operator/vendor/k8s.io/apimachinery/pkg/util/wait/wait.go:152\nk8s.io/apimachinery/pkg/util/wait.JitterUntil\n\t/go/src/github.com/kubevirt/vm-import-operator/vendor/k8s.io/apimachinery/pkg/util/wait/wait.go:153\nk8s.io/apimachinery/pkg/util/wait.Until\n\t/go/src/github.com/kubevirt/vm-import-operator/vendor/k8s.io/apimachinery/pkg/util/wait/wait.go:88"}

That repeated twice.

Then I tried to VM import same VM to default namespace and this VM import worked just fine.

Version-Release number of selected component (if applicable):
CNV-2.4.1

Comment 1 Piotr Kliczewski 2020-09-17 14:16:51 UTC
@Ilanit, please add vm xml that you get from ovirt.

Comment 2 Ilanit Stein 2020-09-21 05:36:22 UTC
Created attachment 1715489 [details]
rhv7-vm-xml.txt

Comment 3 Piotr Kliczewski 2020-09-22 14:08:16 UTC
I tried few times to reproduce but I am not able to with just importing "4519cda0-305e-4359-9fc2-95b6e9b37abe" vm.
@Ilanit please try to reproduce and let me know.

Comment 4 Piotr Kliczewski 2020-10-13 11:43:47 UTC
Due to lack of reproducer I am closing this BZ. Please reopen when you see the issue again.


Note You need to log in before you can comment on or make changes to this bug.