Bug 187999 - move pilot-link dependencies to evolution-pilot subpackage
move pilot-link dependencies to evolution-pilot subpackage
Status: CLOSED DUPLICATE of bug 178155
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-05 05:57 EDT by kloczek
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-07 15:56:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
evolution.spec patch (7.75 KB, patch)
2006-04-05 05:57 EDT, kloczek
no flags Details | Diff

  None (edit)
Description kloczek 2006-04-05 05:57:18 EDT
From:
https://www.redhat.com/archives/fedora-devel-list/2006-April/msg00255.html

Attached patch also fixes few other (sometimes very stupid) things in
this spec:
- remove "Require: libinotify" rule (remember: not versioned libraries
  dependencies are *allways* autogenerated by rpm on build stage),
- replace run sequence autotools by single "autoreconf -f" in %build,
- use --disable-schemas-install in configure parameters instead
  "excercises" in %install,
- remove INSTALL from %doc (God .. now we have in system resources few
  hundrets minus one the same automake INSTALL document),
- replace all --with-<foo>=no and --enable-<bar>=no by better redable
  --without-<foo> and --disable-<bar>,
- use --dissable-static instead waste time in %build for generate static
  libraries only for prune them in %install,
- use single command (rm) for remove all .la files (all without using
  additionaly command like xargs and find),
- cleanups: s,$RPM_BUILD_ROOT/%{_,$RPM_BUILD_ROOT%{_,
Comment 1 kloczek 2006-04-05 05:57:18 EDT
Created attachment 127337 [details]
evolution.spec patch
Comment 2 Matthias Clasen 2006-09-18 20:01:08 EDT
- remove "Require: libinotify" rule (remember: not versioned libraries
  dependencies are *allways* autogenerated by rpm on build stage),

Have you investigated why it was there in the first place ?

- replace run sequence autotools by single "autoreconf -f" in %build,
- use --disable-schemas-install in configure parameters instead
  "excercises" in %install,
- remove INSTALL from %doc (God .. now we have in system resources few
  hundrets minus one the same automake INSTALL document),
- replace all --with-<foo>=no and --enable-<bar>=no by better redable
  --without-<foo> and --disable-<bar>,
- use --dissable-static instead waste time in %build for generate static
  libraries only for prune them in %install,
- use single command (rm) for remove all .la files (all without using
  additionaly command like xargs and find),
- cleanups: s,$RPM_BUILD_ROOT/%{_,$RPM_BUILD_ROOT%{_,

Pretty irrelevant changes. 

It is generally better to produce patches for individual issues. rather
than mixing a sensible idea (evolution-pilot) with a lot of "cleanups".
Comment 3 Matthew Barnes 2006-11-07 15:56:01 EST

*** This bug has been marked as a duplicate of 178155 ***

Note You need to log in before you can comment on or make changes to this bug.