Bug 188038 - MAC address handled improperly if given in UC Hex
MAC address handled improperly if given in UC Hex
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-05 11:19 EDT by bob mckay
Modified: 2014-03-16 22:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-07 09:22:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bob mckay 2006-04-05 11:19:17 EDT
Description of problem:
system-config-network handles MAC addresses specified in upper-case hex improperly

Version-Release number of selected component (if applicable):


How reproducible:
Always (on my machine)

Steps to Reproduce:
1. In the system-config-network gui, specify the MAC address, using upper case for HEX A..F
2. Run Network
3.
  
Actual results:
Simple network connections such as ssh work fine.
http connections hang waiting on the server.
sftp succeeds in establishing a connection, but as soon as you run a command like ls, get or put, it 
hangs.

Expected results:
Network works

Additional info:
The only change necessary to get the network to work was to re-type the MAC address using lower-
case for the HEX (i.e. a..f). 
This is reasonably serious, not because it will affect huge numbers of people (I guess resetting MAC 
addresses isn't all that common, and using upper case takes more work so most people will use lower; I 
got upper case because I was pasting from elsewhere, where it was listed in UC). The problem is, it's 
such an obscure bug, it has taken a _huge_ amount of effort to find. I estimate I have spent probably 40 
hours chasing this. Hopefully, at least people searching bugzilla in future will find it....
Comment 1 bob mckay 2006-04-05 11:47:11 EDT
Just realised, this could be a driver bug rather than system-config-network. So my hardware information 
is relevant: Marvell Yukon II on-board network interface, using the new (with kernel 2.6.16) sky2 default 
driver. If I should be reporting this against sky2 instead, please let me know where I should do this.
Comment 2 Harald Hoyer 2006-04-05 12:02:00 EDT
what is the output of:
# /sbin/ip -o link

/etc/sysconfig/network-scripts/network-functions does the device renaming
according to HWADDR
Comment 3 Bill Nottingham 2006-04-05 22:50:58 EDT
This should be completely case-independent, as well.
Comment 4 bob mckay 2006-04-07 09:22:29 EDT
I have to confess I now can't get it to fail. Switching to upper case does not
now lead to a recurrence of the freezing problem. It may be that the problem was
 dependent on some state in the router. Whatever, this was a problem I had for
around a week, it resolved itself when I reset the mac address in lc, came back
again at the time when I reset it to uc, and finally disappeared when I set it
back to lc. But now, setting it to uc does not screw up the network connection.
FWIW, here is the /sbin/ip -o link output with uc:

2: eth0: <BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast qlen 1000\   
link/ether 00:15:f2:ae:f0:1b brd ff:ff:ff:ff:ff:ff

output is identical with lc. I will reset the status to 'works for me', in case
anyone else hits the same problem.

Note You need to log in before you can comment on or make changes to this bug.