Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1880422 - RHACM logout is broken on OCP 4.6
Summary: RHACM logout is broken on OCP 4.6
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oauth-apiserver
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.7.0
Assignee: Stefan Schimanski
QA Contact: Xingxing Xia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-18 13:40 UTC by Yu Cao
Modified: 2020-10-02 08:44 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-02 08:44:49 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Yu Cao 2020-09-18 13:40:52 UTC
Description of problem:
Failed to log out RHACM on OCP 4.6

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. installed OCP 4.6 and then install RHACM
2. after successful installation, log into RHACM console
3. click on the header and try to logout

Actual results:
RHACM stays on the same page and was not logged out

Expected results:
Logged out and being redirected to login page

Additional info:
After some investigation, there was an api change that's causing logout no longer works for RHACM on OCP 4.6. OCP console also had same issue https://bugzilla.redhat.com/show_bug.cgi?id=1869966
I was able to find the change OCP console made https://github.com/openshift/console/commit/8c5c54024515af9a721e54202c9f5333ffade01e and made similar change in RHACM to fix the problem.

Due to this API change, RHACM team also needs to back port the fix to 2.0z stream.

Although the problem has been fixed, RHACM team would still like to open an issue on OCP team and see how we can work together to prevent similar situation from happening again in the future.


Note You need to log in before you can comment on or make changes to this bug.