Bug 188053 - [a11y] Open Office Presentation Crashes frequently
[a11y] Open Office Presentation Crashes frequently
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-05 12:20 EDT by Sam Folk-Williams
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 2.0.2-5.9.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-03 03:22:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 63583 None None None Never

  None (edit)
Description Sam Folk-Williams 2006-04-05 12:20:07 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Very

Steps to Reproduce:
1. Open a Presentation
2. Work for a while
3.
  
Actual results:
OOCrashes with this:

Video Driver is probably: radeon
Desktop is: GNOME
libgcj version is: libgcj-4.1.0-3
kernel is: Linux 2.6.16-1.2080_FC5 #1 Tue Mar 28 03:38:34 EST 2006 i686 i686 i386
OpenOffice.org core rpm version is: openoffice.org-core-2.0.2-5.7.2
accessibility is: false
...start sestatus details ...
SELinux status:                 disabled
...end sestatus details ...
0x188680: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1e680
0x188ec0: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1eec0
0x8ac420:  + 0x420 (__kernel_sigreturn + 0x0)
0x3ea05b6: /usr/lib/openoffice.org2.0/program/libsvt680li.so + 0x1325b6
0x3ea05d0: /usr/lib/openoffice.org2.0/program/libsvt680li.so + 0x1325d0
0x39e22f6: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x832f6
0x39f03aa: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x913aa
(VclEventListeners::Call(VclSimpleEvent*) const + 0x28)
0x3b1f365: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1c0365
(Window::CallEventListeners(unsigned long, void*) + 0x69)
0x3ed75cf: /usr/lib/openoffice.org2.0/program/libsvt680li.so + 0x1695cf
(TabBar::Clear() + 0x99)
0x5a1c3a6: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0x1013a6
0x5a43b3b: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0x128b3b
0x3869f79: /usr/lib/openoffice.org2.0/program/libsvl680li.so + 0x87f79
(SfxBroadcaster::Broadcast(SfxHint const&) + 0x43)
0x4f63f5a: /usr/lib/openoffice.org2.0/program/libsvx680li.so + 0x573f5a
(SdrModel::InsertPage(SdrPage*, unsigned short) + 0xb8)
0x4fb4b94: /usr/lib/openoffice.org2.0/program/libsvx680li.so + 0x5c4b94
(FmFormModel::InsertPage(SdrPage*, unsigned short) + 0x54)
0x5ae308e: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0x1c808e
0x5ae3b32: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0x1c8b32
0x5ae3d5a: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0x1c8d5a
0x5ae40d5: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0x1c90d5
0x5a162cc: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0xfb2cc
0x5bee9d7: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0x2d39d7
0x5beeff5: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0x2d3ff5
0x5be50bd: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0x2ca0bd
0x5bdafae: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0x2bffae
0x5bdaaa4: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0x2bfaa4
0x45fe472: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1ae472
0x45fd671: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1ad671
0x45fdb48: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1adb48
(SfxDispatcher::_Execute(SfxShell&, SfxSlot const&, SfxRequest&, unsigned short)
+ 0x12e)
0x46076c4: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1b76c4
0x4607991: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1b7991
0x4607ad1: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1b7ad1
(SfxBindings::Execute(unsigned short, SfxPoolItem const**, unsigned short,
unsigned short, SfxPoolItem const**) + 0x35)
0x4616b17: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1c6b17
0x4616b68: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1c6b68
0x39e22f6: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x832f6
0x3aec68a: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x18d68a
(Menu::Select() + 0x3e)
0x3aed232: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x18e232
0x3aee288: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x18f288
(PopupMenu::Execute(Window*, Rectangle const&, unsigned short) + 0x42)
0x3aee2c5: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x18f2c5
(PopupMenu::Execute(Window*, Point const&) + 0x37)
0x46169e8: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1c69e8
0x46174ab: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1c74ab
0x45fc6f4: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1ac6f4
(SfxDispatcher::ExecutePopup(ResId const&, Window*, Point const*) + 0x78)
0x5be6356: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0x2cb356
0x5bdae1f: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0x2bfe1f
0x5a18cc8: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0xfdcc8
0x3b2e471: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1cf471
0x3b30197: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1d1197
0x3b316cb: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1d26cb
0x3b304fd: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1d14fd
0xe2b1b0: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x301b0
0xe2a349: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x2f349
0x56684de: /usr/lib/libgtk-x11-2.0.so.0 + 0x1234de
0xbfbf6d: /usr/lib/libgobject-2.0.so.0 + 0x8f6d (g_closure_invoke + 0x11d)
0xc0ca3d: /usr/lib/libgobject-2.0.so.0 + 0x19a3d
0xc0dd0f: /usr/lib/libgobject-2.0.so.0 + 0x1ad0f (g_signal_emit_valist + 0x68f)
0xc0e109: /usr/lib/libgobject-2.0.so.0 + 0x1b109 (g_signal_emit + 0x29)
0x5753028: /usr/lib/libgtk-x11-2.0.so.0 + 0x20e028
0x5661ec3: /usr/lib/libgtk-x11-2.0.so.0 + 0x11cec3 (gtk_propagate_event + 0x183)
0x5663117: /usr/lib/libgtk-x11-2.0.so.0 + 0x11e117 (gtk_main_do_event + 0x317)
0x3c093a: /usr/lib/libgdk-x11-2.0.so.0 + 0x4093a
0xb7209d: /usr/lib/libglib-2.0.so.0 + 0x2509d (g_main_context_dispatch + 0x16d)
0xb7532f: /usr/lib/libglib-2.0.so.0 + 0x2832f
0xb75895: /usr/lib/libglib-2.0.so.0 + 0x28895 (g_main_context_iteration + 0x65)
0xe0f901: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x14901
0xe7e21d: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x4321d
(X11SalInstance::Yield(unsigned char) + 0x27)
0x39e9866: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8a866
(Application::Yield() + 0x48)
0x39e98ea: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8a8ea
(Application::Execute() + 0x26)
0x58970bb: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x280bb
(desktop::Desktop::Main() + 0x15af)
0x39ed956: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8e956
0x39eda09: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8ea09 (SVMain()
+ 0x2b)
0x588fbf3: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x20bf3 (sal_main
+ 0x57)
0x588fc3f: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x20c3f (main + 0x27)
0x8df7e4: /lib/libc.so.6 + 0x157e4 (__libc_start_main + 0xdc)
0x80484d1: /usr/lib/openoffice.org2.0/program/simpress.bin + 0x4d1


Expected results:
No Crash

Additional info:

Most of the files I'm working with were created on OOO1 on RHEL 4. Crash seems
to happen often when inserting new slide, but also has happened at many other
random times. System is fully updated as of 4/5/2006
Comment 1 Caolan McNamara 2006-04-05 15:17:48 EDT
I guess there isn't a reproducable route to get the crash ?, like a sample
document which always does it.
Comment 2 Caolan McNamara 2006-04-06 06:53:40 EDT
trace looks like this with the line nos re-inserted

/usr/src/debug/OOB680_m5/sal/osl/unx/signal.c:484
/usr/src/debug/OOB680_m5/sal/osl/unx/signal.c:811
0x8ac420:  + 0x420 (__kernel_sigreturn + 0x0)
/usr/src/debug/OOB680_m5/svtools/source/brwbox/editbrowsebox.cxx:733
/usr/src/debug/OOB680_m5/svtools/source/brwbox/editbrowsebox.cxx:1169
/usr/src/debug/OOB680_m5/solver/680/unxlngi6.pro/inc/tools/gen.hxx:76
/usr/src/debug/OOB680_m5/vcl/source/gdi/bitmap.cxx:663
/usr/src/debug/OOB680_m5/vcl/source/window/window.cxx:907
/usr/src/debug/OOB680_m5/solver/680/unxlngi6.pro/inc/tools/table.hxx:99
../../../unxlngi6.pro/inc/sdslots.hxx:1056
/usr/src/debug/OOB680_m5/sd/source/ui/view/PaneManager.cxx:902
/usr/src/debug/OOB680_m5/svtools/source/memtools/svarray.cxx:98
/usr/src/debug/OOB680_m5/svx/source/form/fmPropBrw.cxx:194
/usr/src/debug/OOB680_m5/svx/source/form/fmtools.cxx:1012
/usr/src/debug/OOB680_m5/sd/source/core/CustomAnimationEffect.cxx:2686
/usr/src/debug/OOB680_m5/sd/source/core/CustomAnimationEffect.cxx:873
/usr/src/debug/OOB680_m5/solver/680/unxlngi6.pro/inc/com/sun/star/uno/Any.hxx:495
/usr/include/boost/detail/sp_counted_base_gcc_x86.hpp:109
/usr/src/debug/OOB680_m5/sd/source/ui/view/drviewse.cxx:1432
0x5bee9d7: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0x2d39d7
0x5beeff5: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0x2d3ff5
../../../unxlngi6.pro/inc/com/sun/star/presentation/XSlideShow.hpp:188
/usr/src/debug/OOB680_m5/sd/source/ui/slideshow/showwin.cxx:440
/usr/src/debug/OOB680_m5/sd/source/ui/slideshow/showwin.cxx:104
/usr/src/debug/OOB680_m5/sfx2/source/control/macrconf.cxx:204
/usr/src/debug/OOB680_m5/sfx2/source/control/macrconf.cxx:262
/usr/src/debug/OOB680_m5/sfx2/source/control/macrconf.cxx:216
/usr/src/debug/OOB680_m5/sfx2/source/menu/virtmenu.cxx:814
/usr/src/debug/OOB680_m5/sfx2/source/menu/virtmenu.cxx:311
/usr/src/debug/OOB680_m5/sfx2/source/menu/virtmenu.cxx:1256
/usr/src/debug/OOB680_m5/sfx2/source/statbar/stbitem.cxx:354
/usr/src/debug/OOB680_m5/solver/680/unxlngi6.pro/inc/vcl/event.hxx:278
/usr/src/debug/OOB680_m5/solver/680/unxlngi6.pro/inc/tools/gen.hxx:76
/usr/src/debug/OOB680_m5/vcl/source/window/scrwnd.cxx:92
/usr/src/debug/OOB680_m5/vcl/source/window/split.cxx:500
/usr/src/debug/OOB680_m5/vcl/source/window/split.cxx:436
/usr/src/debug/OOB680_m5/vcl/source/window/split.cxx:642
/usr/src/debug/OOB680_m5/sfx2/source/statbar/stbitem.cxx:330
/usr/src/debug/OOB680_m5/sfx2/source/dialog/filtergrouping.cxx:963
/usr/src/debug/OOB680_m5/sfx2/source/control/macro.cxx:428
../../../unxlngi6.pro/inc/com/sun/star/presentation/XSlideShow.hpp:493
/usr/src/debug/OOB680_m5/sd/source/ui/slideshow/showwin.cxx:471
/usr/src/debug/OOB680_m5/sd/source/ui/view/drviewsf.cxx:249
/usr/src/debug/OOB680_m5/vcl/source/control/button.cxx:2102
/usr/src/debug/OOB680_m5/vcl/source/control/button.cxx:2332
/usr/src/debug/OOB680_m5/vcl/source/control/button.cxx:3670
/usr/src/debug/OOB680_m5/vcl/source/control/button.cxx:2733
../../../inc/salframe.hxx:302
/usr/src/debug/OOB680_m5/vcl/unx/gtk/window/gtkframe.cxx:1969
Comment 3 Sam Folk-Williams 2006-04-06 09:41:50 EDT
i do have a document that it keeps happening on, though it's confidential. lemme
see if i can clean it up and post it.
Comment 4 Caolan McNamara 2006-04-06 09:59:17 EDT
If its only "internal" confidential you can mail it directly to me of course.
Comment 5 Caolan McNamara 2006-04-06 11:16:26 EDT
reproducable, excellent!
Comment 6 Caolan McNamara 2006-04-06 11:24:27 EDT
But interestingly I can only reproduce this when accessibility is enabled,
despite what the crash report reports, in a gnome terminal what does 

> echo $GTK_MODULES 
say ?

If you have accessibility enabled somehow, disabling it will likely give you a
more stable experience while I work on this.
Comment 7 Sam Folk-Williams 2006-04-06 11:56:58 EDT
Interesting -- I had seen that recommendation from an earlier bug. So, I had
turned off accesibility but I did not restart gnome. Now that I have restarted
gnome it is *really* turned off. Will update if it's better/worse.

Thanks,
Sam
Comment 8 Caolan McNamara 2006-04-06 12:22:32 EDT
Aha, that would explain "accessibility false" in the crashlog, but a11y only
reproducability

Note You need to log in before you can comment on or make changes to this bug.