Bug 188062 - ldconfig complains about /usr/lib/libhesiod.so.0
ldconfig complains about /usr/lib/libhesiod.so.0
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: prelink (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
: Reopened
: 145983 189565 193175 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-05 13:21 EDT by Horst H. von Brand
Modified: 2007-11-30 17:11 EST (History)
7 users (show)

See Also:
Fixed In Version: 0.3.8-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-21 07:08:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Horst H. von Brand 2006-04-05 13:21:34 EDT
Description of problem:
ldconfig says:

  /usr/lib/libhesiod.so.0 is not a symlink

Version-Release number of selected component (if applicable):
hesiod-3.1.0-3

How reproducible:
Always (and is quite annoying when you update anything that needs to run ldconfig)

Steps to Reproduce:
1. ldconfig
2.
3.
  
Actual results:
ldconfig: /usr/lib/libhesiod.so.0 is not a symbolic link

Expected results:

Additional info:
Comment 1 Nalin Dahyabhai 2006-04-05 15:11:07 EDT
Can you run "rpm -V hesiod" on your system to verify that the package is
properly installed?  On my systems, it actually is a symlink, and the RPM
package (checked with "rpm -qlv") lists it as one as well.
Comment 2 Horst H. von Brand 2006-04-05 18:05:34 EDT
  [root@laptop11 ~]# rpm -V hesiod
  SM5.....    /usr/lib/libhesiod.so.0

Something's fishy...

OK, installed the package again, rpm(1) and ldconfig(8) are happy.

Thanks!
Comment 3 Karsten Hopp 2006-04-06 07:53:53 EDT
You're not alone, I had the same issue. Something is wrong here.
libhesiod.so.0.0.0 and libhesiod.so.0 have both been regular files on my system,
but with different filelengths. I've reinstalled hesiod and everything is ok now.
Comment 4 Horst H. von Brand 2006-04-06 22:23:15 EDT
Just as here, the .0 is slightly longer and has the same timestamp. Perhaps
something in the upgrades is overwriting the symlink?
Comment 5 Nalin Dahyabhai 2006-04-07 13:00:37 EDT
CCing the anaconda team, in case they can provide a clue as to what's going on here.
Comment 6 Paul Nasrat 2006-04-10 14:21:13 EDT
I just updated from FC5 to rawhide hesiod and didn't see this.  Is there a
reproducible path for getting this?
Comment 7 Paul Nasrat 2006-04-11 11:19:57 EDT
OK between updating yesterday and today with a prelink run inbetween I got the
same failure.  I rpm -V'd post install yesterday.
Comment 8 Paul Nasrat 2006-04-11 11:36:37 EDT
I can replicate:

[root@enki ~]# prelink -av -mR
<stuff>
[root@enki ~]# rpm -Vv hesiod
.........   /usr/lib/libhesiod.so.0
.........   /usr/lib/libhesiod.so.0.0.0
.........   /usr/share/doc/hesiod-3.1.0
......... d /usr/share/doc/hesiod-3.1.0/NEWS
......... d /usr/share/doc/hesiod-3.1.0/README
......... d /usr/share/man/man5/hesiod.conf.5.gz
[root@enki ~]# prelink -u /usr/lib/libhesiod.*so*
prelink: /usr/lib/libhesiod.so does not have .gnu.prelink_undo section
[root@enki ~]# rpm -Vv hesiod
SM5......   /usr/lib/libhesiod.so.0
.........   /usr/lib/libhesiod.so.0.0.0
.........   /usr/share/doc/hesiod-3.1.0
......... d /usr/share/doc/hesiod-3.1.0/NEWS
......... d /usr/share/doc/hesiod-3.1.0/README
......... d /usr/share/man/man5/hesiod.conf.5.gz
Comment 9 Nalin Dahyabhai 2006-04-21 11:20:21 EDT
*** Bug 189565 has been marked as a duplicate of this bug. ***
Comment 10 Reuben Farrelly 2006-05-01 07:25:13 EDT
Happens on my system too - every day it seems - noticeable after a yum update to
rawhide.  I'm on x86_64, so this is not i386 specific.
Comment 11 Jakub Jelinek 2006-05-23 05:34:16 EDT
Should be fixed in prelink-0.3.7-1.
Comment 12 Jakub Jelinek 2006-05-23 05:39:32 EDT
*** Bug 145983 has been marked as a duplicate of this bug. ***
Comment 13 Jakub Jelinek 2006-05-26 06:17:28 EDT
*** Bug 193175 has been marked as a duplicate of this bug. ***
Comment 14 Christian Krause 2006-05-26 08:55:01 EDT
One question: Will this fix be backported to FC5, too? Because my bug report
against FC5 was closed as duplicate of this bug (which is already closed), but
the problem still persists.
Comment 15 Christian Krause 2006-06-02 10:49:23 EDT
Hi Jakub,

(In reply to comment #11)
> Should be fixed in prelink-0.3.7-1.

I'm sorry for the bug spam, but I didn't got an answer to my question for one
week. Please can you give a short statement whether the fix will be backported
to FC5 or which steps are necessary to achieve this? Thank you very much for
your help.


Comment 16 Horst H. von Brand 2006-06-02 22:55:39 EDT
(In reply to comment #11)
> Should be fixed in prelink-0.3.7-1.

Isn't. Still the same here (rawhide, i386).
Comment 17 Jakub Jelinek 2006-06-03 02:10:08 EDT
Have you downgraded hesiod, prelinked, upgraded hesiod and prelinked again
to verify?
No prelink change can retroactively change what the bug caused, it has no means
to find out something should have been a symlink (to what) rather than a file.
Comment 18 Horst H. von Brand 2006-06-03 13:48:06 EDT
I just did the following:
 
  rm /usr/lib/libhesiod.so.0
  ldconfig
  prelink --all

Now it is not a file anymore. But I've done the first two a few times, and
during the next update the complaints are back.
Comment 19 Jakub Jelinek 2006-06-21 07:08:46 EDT
prelink-0.3.8-1 contains a better fix for this problem.

Note You need to log in before you can comment on or make changes to this bug.