Bug 188103 - yum and yumex fail with urlopen eror 2 no such file or directory
yum and yumex fail with urlopen eror 2 no such file or directory
Status: CLOSED DUPLICATE of bug 186592
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
4
All Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-05 21:38 EDT by Joe Acosta
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-10 16:17:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Acosta 2006-04-05 21:38:25 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. run yum update
2. it fails
3. on fedora core 4 after last update 
  
Actual results:
yum update
Setting up Update Process
Setting up repositories
http://download.fedora.redhat.com/pub/fedora/linux/core/4/i386/os/repodata/repomd.xml:
[Errno 4] IOError: <urlopen error (2, 'No such file or directory')>
Trying other mirror.
Cannot open/read repomd.xml file for repository: base
failure: repodata/repomd.xml from base: [Errno 256] No more mirrors to try.
Error: failure: repodata/repomd.xml from base: [Errno 256] No more mirrors to try.


Expected results:
it should spit out a bunch of messages like it normally does

Additional info:
Name        : yum                          Relocations: (not relocatable)
Version     : 2.4.1                             Vendor: Red Hat, Inc.
Release     : 1.fc4                         Build Date: Mon 05 Dec 2005 08:09:17
AM PST
Install Date: Fri 23 Dec 2005 06:46:00 PM PST      Build Host:
hs20-bc1-4.build.redhat.com
Group       : System Environment/Base       Source RPM: yum-2.4.1-1.fc4.src.rpm
Size        : 1249806                          License: GPL
Signature   : DSA/SHA1, Mon 12 Dec 2005 10:11:06 AM PST, Key ID b44269d04f2a6fd2
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://linux.duke.edu/yum/
Summary     : RPM installer/updater
Description :
Yum is a utility that can check for and automatically download and
install updated RPM packages. Dependencies are obtained and downloaded
automatically prompting the user as necessary.
Comment 1 Joe Acosta 2006-04-07 19:39:00 EDT
I think I found a work around.

It seems that after the last time I ran yum it upgraded my nsswitch.conf file.

It changed my hosts settings in that file to:

hosts:      files nisplus dns

I changed it back to:  file dns nisplus as I don't use nis.

It now seems to work again.

I think the bug is in glibc-2.3.6-3 assuming everyone uses nis
 
Comment 2 Jeremy Katz 2006-04-10 14:52:04 EDT
Caused by a glibc bug
Comment 3 Jakub Jelinek 2006-04-10 16:17:56 EDT

*** This bug has been marked as a duplicate of 186592 ***

Note You need to log in before you can comment on or make changes to this bug.