Bug 188114 - FC5 fails to mount partitions at boot (automount).
FC5 fails to mount partitions at boot (automount).
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-06 00:48 EDT by M. A. MacLain
Modified: 2014-03-16 22:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-08 21:31:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description M. A. MacLain 2006-04-06 00:48:46 EDT
Description of problem:
FC5 fails to mount partitions at boot (automount). The partitions do mount
correctly after boot command line. A Fedora Core 4 install do automount the
partitions correctly (multiboot system).

Boot message reads:
..............................................................................
.
.
Mounting other file systems: mount: block device /dev/hda7 is write-protected,
mounting read-only
mount: cannot mount block device /dev/hda7 read-only
mount: block device /dev/hda8 is write-protected, mounting read-only
mount: cannot mount block device /dev/hda8 read-only
.
.
...............................................................................
fstab:
LABEL=/123 / ext3 defaults 1 1
devpts /dev/pts devpts gid=5,mode=620 0 0
tmpfs /dev/shm tmpfs defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs defaults 0 0
/dev/hdd1 swap swap defaults 0 0
/dev/hda7 /home/Ldat ext3 defaults 0 0
/dev/hda8 /home/Wdat auto defaults 0 0

Version-Release number of selected component (if applicable):

How reproducible:
Consistent. Tested another intall with same results.

Steps to Reproduce:
1. Created directories : ?home /Ldat and /home/Wdat
2. Added to fstab:  /dev/hda7 /home/Ldat ext3 defaults 0 0
                   /dev/hda8 /home/Wdat auto defaults 0 0
3. Reboot
  
Actual results: Partitions not mounted


Expected results: Partitions mounted


Additional info: Note the "write protected" part of boot message.
Comment 1 M. A. MacLain 2006-05-09 08:56:34 EDT
Please remove this from bugzilla, it is not a bug. SELinux, for security
reasons, disallows mounting the already created partitions. The solution is to
change the security context of the directory where the partition is to be
mounted to mnt_t ( that of a new system). To do this the "chcon" directive is
used twice, once with the partition unmounted to change the "context user_u" and
then after mounting the partition to change the "system_u" of the directory.
(fstab must have the corresponding mount statement(s).  A more detailed SELinux
would help avoid this type of problems.
M. A. MacLain

Note You need to log in before you can comment on or make changes to this bug.