Bug 188127 - Buggy NFS in new kernel
Buggy NFS in new kernel
Status: CLOSED DUPLICATE of bug 186142
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Layton
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2006-04-06 06:08 EDT by Klaus Ethgen
Modified: 2009-05-13 06:04 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-01-15 06:37:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Klaus Ethgen 2006-04-06 06:08:00 EDT
Description of problem:
 With the kernel 2.6.9-34.EL svn do not work on specific situations. (See
 below.) The Error message will be:
 svn: REPORT Anfrage fehlgeschlagen auf '/xxxx/!svn/vcc/default'
 svn: REPORT von '/xxxx/!svn/vcc/default': 400 Bad Request (https://svn.xx.xxxx.xx)

 A small googeling points to problemes when proxy is used. But in my case no
 proxy is be used (as you can see on the "https").

Version-Release number of selected component (if applicable): 2.6.9-34.EL*

Steps to Reproduce:
1. Set up a NFS server under EL3 or 7.3
2. Set up a server which provides a svn repository over http or https
3. Set up a client workstation EL4 with kernel versuion 2.6.9-34.EL or
4. Mount your home (or whatever path) on the workstation from your older server
5. go to the mounted directory
6. try to checkout a svn from the above https repository

Actual results:
It fails with the error above

Expected results:
Well, of cause a checkout!

Additional info:
- The bug is independend of the locales
- The bug do not happens if the NFS server is a EL4 or a Sun
- The bug do not happens with older Kernel like 2.6.9-22.0.2.EL*
- The bug do not happens if the dir where you want to checkout is a local dir
- The bug is independend of subversion version. I also tried the newest self
compiled version.
- The bug do not happens if you use other repositories like svn+ssh or local
- The bug seems to also be relevant to other software. 'have several heisenbugs
with the new kernel I can not show how to reproduce.
Comment 1 Jeff Layton 2007-07-20 06:52:56 EDT
This is likely a duplicate of bug #186142. Do you still see this problem on a
4.5 kernel (-55.EL)?
Comment 2 Klaus Ethgen 2007-11-12 07:56:24 EST
I am not aware to see the bug #186142 so I cannot check if the problem is the 

We just have no EL3 server running right now. So to check if the bug is still 
there or not is not possible at the moment. I have to setup a EL3 server first. 
Be patient.
Comment 3 Jeff Layton 2007-11-12 08:16:44 EST
I've cc'ed you on BZ 186142, so you should be able to access it now. I'll leave
this in NEEDINFO state for now until you're able to test it.

Comment 4 Jeff Layton 2007-11-12 08:28:09 EST
For the record, I think this is a dupe of bug 187356, which was eventually
closed as a dupe of bug 186142.
Comment 5 Jeff Layton 2008-01-15 06:37:46 EST
No response in several months. I'm going to go ahead and close this case as a
dupe of 186142. Please reopen if you're still able to reproduce this on more
current kernels.

*** This bug has been marked as a duplicate of 186142 ***
Comment 6 Klaus Ethgen 2009-05-13 06:04:47 EDT
Yes, sorry for not answering.

The bug is not important for us anymore as we do not use EL3 anymore.

So if it is supposely fixed that is ok for me.

Note You need to log in before you can comment on or make changes to this bug.