Bug 188134 - duplicate strings with IM
duplicate strings with IM
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-06 06:38 EDT by Akira TAGOH
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-27 17:56:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Bug does not appears (119.47 KB, image/png)
2006-06-20 01:37 EDT, Mayank Jain
no flags Details

  None (edit)
Description Akira TAGOH 2006-04-06 06:38:44 EDT
Description of problem:
When I type and convert and commit something through IM, then press enter to
move a cursor to the beginning of line, if I do the same steps, duplicate
strings appears on textarea. it looks like preedit isn't reset after commit.

Version-Release number of selected component (if applicable):
3.3.5-13

How reproducible:
always

Steps to Reproduce:
1.run kedit on LANG=ja_JP.UTF-8
2.press ctrl+space, nihongo space enter enter then, nihongo space enter
3.
  
Actual results:
it looks like:
日本語
nに日本語

Expected results:
it should be:
日本語
日本語

Additional info:
this bug doesn't appears on fc6. so qtimm patch may causes this?
Comment 1 Ngo Than 2006-05-17 13:17:47 EDT
i tried to reproduce this problem with above steps, but somehow it does not work
as you describe above. I did not see any japanese characters in kedit!

Could you please give exactly steps to reproduce this problem please? Thanks


Comment 3 A S Alam 2006-06-14 02:34:19 EDT
this problem is still exist on Rawhide, changing Version and Assign it again.
Tested on:
qt-3.3.6-7
Comment 4 Jong Bae KO 2006-06-15 04:53:55 EDT
------- Additional Comments From aalam@redhat.com  2006-06-13 05:31 EST -------
Not yet fixed, Problem till exist in Rawhide:
Test with following package:
qt-3.3.6-7
Comment 5 Mayank Jain 2006-06-20 01:37:15 EDT
Created attachment 131173 [details]
Bug does not appears

My kedit dosnt seems to have this problem
kdebase-3.5.2-10
qt-3.3.6-5
Comment 6 Ngo Than 2006-06-21 12:25:34 EDT
could someone please describe exactly steps how i can enable input method to 
reproduce this problem? and what packages should be installed here?  Thanks






Comment 7 Ngo Than 2006-06-27 17:56:20 EDT
i cannot reproduce this problem with qt-3.3.6-8 in rawhide.
Comment 8 Mayank Jain 2006-06-28 01:55:27 EDT
Thanks Ngo Than for verifying :)

Note You need to log in before you can comment on or make changes to this bug.