Bug 1881342 - qemu-5.1.0-4.eln103 fails to rebuild in ELN buildroot
Summary: qemu-5.1.0-4.eln103 fails to rebuild in ELN buildroot
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: systemtap
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Frank Ch. Eigler
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-22 08:40 UTC by Kamil Dudka
Modified: 2020-09-24 06:45 UTC (History)
18 users (show)

Fixed In Version: systemtap-4.4-0.20200922git05179173e71c.eln103
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-24 06:45:28 UTC
Type: Bug


Attachments (Terms of Use)

Description Kamil Dudka 2020-09-22 08:40:45 UTC
Version-Release number of selected component (if applicable):
qemu-5.1.0-4.eln103


How reproducible:
Easily.


Steps to Reproduce:
1. koji buildinfo $(koji latest-build --quiet eln qemu | cut -f1 -d' ') | grep ^Task
2. koji build --scratch eln git+https://src.fedoraproject.org/rpms/qemu.git:dc03f389d339a92a50a6206b62af58ad50e6bd80


Actual results:
[...]
DEBUG util.py:621:  Error: 
DEBUG util.py:621:   Problem: package systemtap-4.4-0.20200909git82b8e1a07.eln103.x86_64 requires systemtap-client = 4.4-0.20200909git82b8e1a07.eln103, but none of the providers can be installed
DEBUG util.py:621:    - package systemtap-client-4.4-0.20200909git82b8e1a07.eln103.x86_64 requires systemtap-runtime = 4.4-0.20200909git82b8e1a07.eln103, but none of the providers can be installed
DEBUG util.py:621:    - conflicting requests
DEBUG util.py:621:    - nothing provides libdyninstAPI.so.10.1()(64bit) needed by systemtap-runtime-4.4-0.20200909git82b8e1a07.eln103.x86_64
DEBUG util.py:623:  (try to add '--skip-broken' to skip uninstallable packages)
DEBUG util.py:774:  Child return code was: 1


Expected results:
Successful build.


Additional info:
scratch build: https://koji.fedoraproject.org/koji/taskinfo?taskID=52003507

Comment 2 Daniel Berrangé 2020-09-22 08:44:33 UTC
The error message in bug description clearly shows that the problem is broken systemtap package. Please file a bug against systemtap and once that's fixed, QEMU should work.

Comment 3 Frank Ch. Eigler 2020-09-22 10:20:24 UTC
There is nothing wrong with the systemtap build under our control (.fc34 etc.); those are built against the rawhide dyninst-10.2 rpms.  The .eln103 build bots must have a screwed up buildroot and didn't do the dyninst->systemtap chain build right.  In any case, started a rawhide systemtap-only respin; hope .eln gets it right.

systemtap-4.4-0.20200922git05179173e71c.fc34.src.rpm

Comment 4 Mark Wielaard 2020-09-22 10:25:15 UTC
Yeah, got the same issue recently https://lists.fedorahosted.org/archives/list/devel@lists.fedoraproject.org/thread/KHPFT3XOZVDQIESXGNFWFAWCB5SKNBCX/ apparently ELN doesn't sync the buildroot before doing new builds.

Comment 5 Kamil Dudka 2020-09-22 10:34:23 UTC
Thank you for taking a quick action on this!

Comment 6 Kamil Dudka 2020-09-24 06:45:28 UTC
systemtap-4.4-0.20200922git05179173e71c.eln103 works.  I am able to build/scan qemu now.  Thanks!


Note You need to log in before you can comment on or make changes to this bug.