Bug 188143 - Fails to start - Bonobo error
Fails to start - Bonobo error
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: mail-notification (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thorsten Leemhuis
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-06 09:05 EDT by Nigel Metheringham
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-06 08:46:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nigel Metheringham 2006-04-06 09:05:06 EDT
Description of problem:
Sometimes mail-notification fails to start, if started after login, putting up a
dialog:-

  A fatal error has occurred in Mail Notification

  Bonobo was unable to register the   
  OAFIID:GNOME_MailNotification_Automation_Factory server.
  Please check your Mail Notification installation.

If started at login it always starts, however sometimes it then blocks evolution
from starting up - the error given then is that the evolution-data-server
version is too old

Version-Release number of selected component (if applicable):
  mail-notification-2.0-11.fc5
  evolution-2.6.0-1
  evolution-data-server-1.6.0-1

  [Current FC5 + extras with updates as of 6 Apr]

How reproducible:
  50% of sessions or more


Additional info:

Thought this might be related to the evolution-data-server update after FC5
release, so rebuilt the SRPM with current libraries etc.  This had no effect on
the problem.
Comment 1 Thorsten Leemhuis 2006-04-08 13:19:23 EDT
I have no idea what's wrong here. I'm using mail-notification on different
machines and never faced problems like that. Did you try to reinstall
mail-notification? Do the same problems show up on a fresh user account?
Comment 2 Nigel Metheringham 2006-04-11 07:35:04 EDT
I'm having trouble recreating this on a clean account.
Obviously it requires you to be monitoring an evolution mailbox rather than one
of the other methods.  In my case I have 4 evolution folders, 2 on each of the
two defined IMAP servers I have (I did not configure the clean account with such
complexity).

I do have beagle running - this does tie into the evolution libraries and the
data server so maybe thats a clue (I did not configure beagle on the clean account).

I guess the thing to do is to leave this bug in a NEEDINFO state and see if I or
anyone else can add information to it.  No point flagging it under evolution
since theres no one in RH looking after that.
Comment 3 Mark Knoop 2006-05-27 10:50:35 EDT
I experienced this bug also. I had used a previous version of mail-notification
and it seems that the old GConf configuration was causing the bug.

mail-notification --unset-obsolete-configuration

followed by a logout seems to have fixed the problem (so far...).
Comment 4 Nigel Metheringham 2006-06-02 04:21:26 EDT
The recipe in comment #3 did not work for me.

Is this related to 
  http://bugzilla.gnome.org/show_bug.cgi?id=343656
Comment 5 Thorsten Leemhuis 2006-08-06 08:46:08 EDT
The package now uses unset-obsolete-configuration -- if this problem sill
exisits please reopen (or even better: tell upstream)

Note You need to log in before you can comment on or make changes to this bug.