Bug 188157 - Kernel panic right after uncompressing the kernel during CD installation on a dual xeon EM64T machine
Kernel panic right after uncompressing the kernel during CD installation on a...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: booty (Show other bugs)
4.0
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Peter Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-06 10:48 EDT by Allen Zhao
Modified: 2008-07-24 14:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-24 14:41:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Allen Zhao 2006-04-06 10:48:52 EDT
Description of problem:

Try to install RHEL4 for x86_64 onto a HP ML150 G2 (dual Xeon EM64T CPU, 1GB RAM
(2x512)) with CD. Right after the kernel uncompress (boot into linux), the
installation got a kernel panic, the last line is something like:
"kernel panic: can not sync, oops. "
Somewhere in the screen, one of the functions shown was something like
initprocessor... 

We tried RHEL4 installer CD for the original release, update 1, and update 3 for
x86_64 distribution, with the same results. All these CDs can boot our dual
opteron server just fine, but panic with em64t server during boot (the setting
of bios of hyperthreading does not matter).

We also tried to boot with RHEL4 for 32-bit, that one works. SuSE ent linux 9
server for x86_64 will also hang. Solaris 10 can be installed. So, it seems that
the 64-bit linux installation all failed. 

But if we do the following, the installation can be done:

1) remove the 2nd CPU
2) run the CD installation (only non-SMP kernel is installed), and get RHEL4
installed
3) boot into RHEL4, manually installed the SMP kernel rpm, and set grub to use
SMP kernel by default
4) poweroff, and install the 2nd CPU again, and then boot up

This will get everything installed and running.

It looks like the 2nd CPU causes the kernel panic during the CD booting. 


Version-Release number of selected component (if applicable):


How reproducible:
Everytime, with RHEL4 for x86_64.

Steps to Reproduce:
1. Insert the Disc 1 of the CD
2. boot server to CD, and at the install screen, just hit enter
3. 
  
Actual results:
After showing kernel uncompressed, panic

Expected results:
show some hardware info, and boot into installation screen


Additional info:

Called HP for support. But they are equally surprised by my news. HP claims that
at least RHEL4 U1 is supported (which also failed anyway for the server I have).

As this happened during the boot, I am not sure how to get the full screen
output here. If someone can give me instruction, I would love to do it.
Comment 1 Allen Zhao 2006-04-06 10:53:58 EDT
One more clarification: I am reporting the RHEL4 AS installation. Never tried
the ES and WS version.
Comment 2 Allen Zhao 2006-04-07 12:09:54 EDT
I think we resolve the issue. The vendor goofed by sending us a SMP server, the
primary CPU with 2MB cache, and the 2nd CPU with only 1MB cache. 

This is causing the boot CD to panic. Removing one of them, or using the CPU
with 1MB cache as the primary CPU, will fix the issue.
Comment 3 Denise Dumas 2008-07-24 14:41:51 EDT
Since the customer's last comment indicates that the issue is resolved by
hardware changes, I am closing this.

Note You need to log in before you can comment on or make changes to this bug.