Bug 188171 - xm top just uses PATH, but sbin might not be in the users path
xm top just uses PATH, but sbin might not be in the users path
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Richard W.M. Jones
Martin Jenner
:
Depends On:
Blocks: 241889
  Show dependency treegraph
 
Reported: 2006-04-06 13:41 EDT by James Antill
Modified: 2008-01-17 12:49 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-17 12:49:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Antill 2006-04-06 13:41:35 EDT
Description of problem:
Fedora doesn't put /sbin and /usr/sbin into a non-root path, so if a user does
sudo /usr/sbin/xm top you get a python traceback (a simple command not found
error message, would also be much nicer).

Version-Release number of selected component (if applicable):
xen-3.0.1-4

How reproducible:
always
Comment 1 Red Hat Bugzilla 2007-07-24 19:41:02 EDT
change QA contact
Comment 2 Richard W.M. Jones 2008-01-17 12:49:55 EST
We should encourage people to use the virt-top command (which is in
Fedora since F8) instead of xm top.  The reason is that virt-top is
more powerful and supports multiple hypervisors through libvirt.

Note You need to log in before you can comment on or make changes to this bug.