Bug 188189 - yumex repeatedly fails to update kernel
yumex repeatedly fails to update kernel
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-06 15:34 EDT by Andy Burns
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-18 09:30:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yum.log (9.28 KB, text/plain)
2006-04-06 15:34 EDT, Andy Burns
no flags Details

  None (edit)
Description Andy Burns 2006-04-06 15:34:13 EDT
Description of problem:

On a freshly installed FC5 I installed yumex, and ran an update using it, it
downloaded and claimed to have successfully updated all packaages from updates
repo. However several packages including kernel 2080_FC5 had not been installed,
repeated attempts to install claimed to have updated but still failed, tried
rebooting, tried yum clean all, still the same.

Used "yum update" instead of yumex and all packages were installed

Version-Release number of selected component (if applicable):
0.99.16-1

How reproducible:
always (but updates in question have now done using yum)

Steps to Reproduce:
1. yumex
2. wait for repos to refresh
3. update, select all, add to queue, process queue
  
Actual results:

About 8 pakages repeatedly failed to install

Expected results:

yumex behaves the same as yum

Additional info:

see attached /var/log/yum.log
Comment 1 Andy Burns 2006-04-06 15:34:13 EDT
Created attachment 127424 [details]
yum.log
Comment 2 Ignacio Vazquez-Abrams 2006-04-06 15:38:45 EDT
Do you see any AVC denial messages in /var/log/audit/audit.log* pointing to yumex?
Comment 3 Andy Burns 2006-04-06 17:46:35 EDT
grep -i yum audit.log finds nothing ...
Comment 4 Tim Lauridsen 2006-04-07 02:28:34 EDT
On my system the AVC messages is written to /var/log/messages.

Try this as root.
grep -i yumex /var/log/messages

Another way to see the problem is by running 'yumex' from the console.
You will see some rpm scriplet error when installing the kernal.


Read about the problem here.
http://linux.rasmil.dk/cms/modules/news/article.php?storyid=56

you have to update you system with 'yum update selinux-policy*' to get the
latest selinux policy installed. (2.2.25-3.fc5), after installation a reboot is
needed. After that you should be able to install the kernal with yumex.



Comment 5 Andy Burns 2006-04-07 04:27:28 EDT
(In reply to comment #4)
> On my system the AVC messages is written to /var/log/messages.

yes I did check /var/log/messges (and even dmesg) for anything yumex related 

> Another way to see the problem is by running 'yumex' from the console.
> You will see some rpm scriplet error when installing the kernal.

I didn't try that, but it's too late now to see if any errors went to the
console, I did manage to "kick" the relevnt upgrades by using yum instead of
yumex, certainly in yumex's output window there were no errors, it claimed to
have installed successfully.

> Read about the problem here.
> http://linux.rasmil.dk/cms/modules/news/article.php?storyid=56

Ok, that's good, so long as the problem is understood, is any more error
checking needed in yumex so that in future it will report the error rather than
mask it?
Comment 6 Tim Lauridsen 2006-04-07 07:47:10 EDT
It is rpm there is repost the scriptlet errors as warning on the console, but it
dont return any errorcode so the yum installation api routines cant detect it as
an error, so yumex thinks that everytings was installed succesfully. The RPM
warnings are written directly to the stdout, so where is no way to redirect so
the  user can see it in the GUI, even when using the python ways to redirect
stdout, dont redirect there errors.

Note You need to log in before you can comment on or make changes to this bug.