Bug 188206 - TBb774d176 yumexDialogs.py:364:writelines:TypeError: GtkTextBuffer.insert() argument 2 must be string or read-only buffer, not None
TBb774d176 yumexDialogs.py:364:writelines:TypeError: GtkTextBuffer.insert() a...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-06 19:07 EDT by Chitlesh GOORAH
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.2.0-1.0.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-13 10:09:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chitlesh GOORAH 2006-04-06 19:07:25 EDT
Description of problem:
Right click on repo livna
Exception Occurred

Version-Release number of selected component (if applicable):
yumex-0.99.16-1.0.fc5

How reproducible:
Everytime

Steps to Reproduce:
1. right click on repo livna
2. exception occurred
3.
  
Actual results:
Component: yumex
Version: 0.99.16
Summary: TBb774d176 yumexDialogs.py:364:writelines:TypeError:
GtkTextBuffer.insert() argument 2 must be string or read-only buffer, not None

Traceback (most recent call last):
  File "/usr/share/yumex/yumexmain.py", line 255, in on_repo_popup
    editrepo = EditRepo( const.GLADE_FILE, activeRepo )
  File "/usr/lib/python2.4/site-packages/yumex/yumexDialogs.py", line 325, in
__init__
    self.update_fields()
  File "/usr/lib/python2.4/site-packages/yumex/yumexDialogs.py", line 357, in
update_fields
    self.writelines( self.URL, urls )
  File "/usr/lib/python2.4/site-packages/yumex/yumexDialogs.py", line 364, in
writelines
    buf.insert( start, lines )
TypeError: GtkTextBuffer.insert() argument 2 must be string or read-only buffer,
not None

Local variables in innermost frame:
start: <GtkTextIter at 0xcf41100>
self: <yumex.yumexDialogs.EditRepo instance at 0xc7c5d8c>
buf: <gtk.TextBuffer object (GtkTextBuffer) at 0xb2a901bc>
lines: None
view: <gtk.TextView object (GtkTextView) at 0xb2bd893c>


Expected results:
A dialog box to edit repo configurations

Additional info:

Second trial ::::
====================

Component: yumex
Version: 0.99.16
Summary: TBb774d176 yumexDialogs.py:364:writelines:TypeError:
GtkTextBuffer.insert() argument 2 must be string or read-only buffer, not None

Traceback (most recent call last):
  File "/usr/share/yumex/yumexmain.py", line 255, in on_repo_popup
    editrepo = EditRepo( const.GLADE_FILE, activeRepo )
  File "/usr/lib/python2.4/site-packages/yumex/yumexDialogs.py", line 325, in
__init__
    self.update_fields()
  File "/usr/lib/python2.4/site-packages/yumex/yumexDialogs.py", line 357, in
update_fields
    self.writelines( self.URL, urls )
  File "/usr/lib/python2.4/site-packages/yumex/yumexDialogs.py", line 364, in
writelines
    buf.insert( start, lines )
TypeError: GtkTextBuffer.insert() argument 2 must be string or read-only buffer,
not None

Local variables in innermost frame:
start: <GtkTextIter at 0xdf9c978>
self: <yumex.yumexDialogs.EditRepo instance at 0xb799c10c>
buf: <gtk.TextBuffer object (GtkTextBuffer) at 0xb0d8d39c>
lines: None
view: <gtk.TextView object (GtkTextView) at 0xb0d5b34c>
Comment 1 Tim Lauridsen 2006-04-07 02:48:36 EDT
Looks like there is no urls definded in you /etc/yum.repos.d/livna.repo file.
How does you licna.repo file like ????

I need to add a check for that, so yumex dont make an exception.
Comment 2 Chitlesh GOORAH 2006-04-07 05:37:42 EDT
True no urls are defined:

my livna.repo
[livna]
name=Livna for Fedora Core $releasever - $basearch - Base
failovermethod=priority
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-livna

[livna-debuginfo]
name=Livna for Fedora Core $releasever - $basearch - Debug
failovermethod=priority
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-livna
gpgcheck=1

[livna-source]
name=Livna for Fedora Core $releasever - $basearch - Source
failovermethod=priority
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-livna
gpgcheck=1
Comment 3 Chitlesh GOORAH 2006-04-07 06:34:26 EDT
It works fine with the following livna.repo:
Nevertheless, it would be nice that it doesn't crash, even if there's no URLS :)


[livna]
name=Livna for Fedora Core $releasever - $basearch - Base
baseurl=
	http://rpm.livna.org/fedora/$releasever/$basearch/
	http://livna.cat.pdx.edu/fedora/$releasever/$basearch/
	http://wftp.tu-chemnitz.de/pub/linux/livna/fedora/$releasever/$basearch/
	http://ftp-stud.fht-esslingen.de/pub/Mirrors/rpm.livna.org/fedora/$releasever/$basearch/
failovermethod=priority
#mirrorlist=http://rpm.livna.org/mirrorlist-5
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-livna

[livna-debuginfo]
name=Livna for Fedora Core $releasever - $basearch - Debug
baseurl=
	http://rpm.livna.org/fedora/$releasever/$basearch/debug/
	http://livna.cat.pdx.edu/fedora/$releasever/$basearch/debug/
	http://wftp.tu-chemnitz.de/pub/linux/livna/fedora/$releasever/$basearch/debug/
	http://ftp-stud.fht-esslingen.de/pub/Mirrors/rpm.livna.org/fedora/$releasever/$basearch/debug/
failovermethod=priority
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-livna
gpgcheck=1

[livna-source]
name=Livna for Fedora Core $releasever - $basearch - Source
baseurl=
	http://rpm.livna.org/fedora/$releasever/SRPMS/
	http://livna.cat.pdx.edu/fedora/$releasever/SRPMS/
	http://wftp.tu-chemnitz.de/pub/linux/livna/fedora/$releasever/SRPMS/
	http://ftp-stud.fht-esslingen.de/pub/Mirrors/rpm.livna.org/fedora/$releasever/SRPMS/
failovermethod=priority
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-livna
gpgcheck=1
Comment 4 Tim Lauridsen 2006-04-07 07:54:06 EDT
I will add some check so it dont crash, when there is no urls in a repo. :-)
Comment 5 Chitlesh GOORAH 2006-04-07 21:39:04 EDT
I don't know to whom to say this, so ill post it here:

My livna.repo file changes everytime yum successfully installed a particular
package, in a sense that it no longer has URLS.

Afterwards my livna.repo looks like
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=188206#c2
Comment 6 Tim Lauridsen 2006-04-10 03:34:04 EDT
(In reply to comment #5)
> I don't know to whom to say this, so ill post it here:
> 
> My livna.repo file changes everytime yum successfully installed a particular
> package, in a sense that it no longer has URLS.
> 
Very weird, have you installed the livna rpm containing the livna repo files ??

I have fixed the traceback, it will be released in 0.99.17.

Comment 7 Chitlesh GOORAH 2006-04-10 08:03:26 EDT
Yes, I've installed the rpm from livna.org
Comment 8 Chitlesh GOORAH 2006-12-13 10:09:27 EST
For some reason, I don't have this bug any more
I'm closing this bug.

Note You need to log in before you can comment on or make changes to this bug.