Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1882189 - Graph can't be displayed with perform metric query with big data
Summary: Graph can't be displayed with perform metric query with big data
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.7.0
Assignee: Andrew Pickering
QA Contact: hongyan li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-24 02:09 UTC by hongyan li
Modified: 2020-10-04 23:55 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-28 02:20:24 UTC
Target Upstream Version:


Attachments (Terms of Use)
Good display (140.94 KB, image/png)
2020-09-24 02:09 UTC, hongyan li
no flags Details
bad display (42.44 KB, image/png)
2020-09-24 02:09 UTC, hongyan li
no flags Details
Another error (98.44 KB, image/png)
2020-09-25 04:02 UTC, hongyan li
no flags Details

Description hongyan li 2020-09-24 02:09:13 UTC
Created attachment 1716192 [details]
Good display

Created attachment 1716192 [details]
Good display

Description of problem:
Graph can't be displayed with perform metric query with big data 

Version-Release number of selected component (if applicable):
4.6.0-0.nightly-2020-09-23-022756

How reproducible:
Always

Steps to Reproduce:
1.Login in cluster console as admin, click "Monitoring -> Metrics"
2.Input query "cluster_quantile:apiserver_request_duration_seconds:histogram_quantile"
3.click button 'Run Queries'

Actual results:
Page displays:
1. Ungraphable results
2. The resulting dataset is too large to graph.

Expected results:
Graph displays well

Additional info:
4.6.0-0.nightly-2020-09-21-093308 can display graph, return 729 series
4.6.0-0.nightly-2020-09-23-022756 can't display, return 1004 data series
Prometheus UI can display graph

Comment 1 hongyan li 2020-09-24 02:09:58 UTC
Created attachment 1716193 [details]
bad display

Comment 2 hongyan li 2020-09-25 04:01:26 UTC
When execute query, graph can't be displayed also, but wit different error 
sort_desc(count({__name__=~"[a-z].*"}) by (__name__))
topk(10,count by (job)({__name__=~".+"}))

Comment 3 hongyan li 2020-09-25 04:02:09 UTC
Created attachment 1716525 [details]
Another error

Comment 4 Andrew Pickering 2020-09-28 02:20:24 UTC
Closing this as NOTABUG

We need to handle the situation where there is too much data to graph in some way. Our current approach is simply to display a message saying there is too much data so the user can adjust the query to return less data. There may be a better approach, but this is currently working as intended.

The second error is being returned by Prometheus. The frontend handles Prometheus errors by displaying the error message in the UI, which I think is the right approach since we don't know what the cause of the error is other than by checking the message. (In the case of a timeout, Prometheus returns a 503 response.)


Note You need to log in before you can comment on or make changes to this bug.