Bug 188221 - dvddecrypter or dvdshrink can not see the CD/DVD
dvddecrypter or dvdshrink can not see the CD/DVD
Status: CLOSED DUPLICATE of bug 183735
Product: Fedora
Classification: Fedora
Component: wine (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-07 02:39 EDT by Jacek Pliszka
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-07 02:45:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jacek Pliszka 2006-04-07 02:39:12 EDT
Description of problem:

When DVDDecypter or DVDShrink are run under wine - they can not find any
DVD device even though /dev/hdc is mounted and seen by mplayer.
The links are made in dosdevices. DVDShrink can be run with:
wine DVDShrink D:
where D: is the DVD dosdevices link.
Ubuntu folks  on some fora claim it works for them - I have not it confirmed though.
I tried with both IDE and USB drive.

Version-Release number of selected component (if applicable):
 0.9.11-1.fc5 

How reproducible:
Always

Steps to Reproduce:
1. Insert DVD in the drive, it gets mounted
2. ensure links in dosdevices:  
   d: and d:: point to mounted directory and raw device
3a. Run dvddecrypter 
3b. Run dvdshrink - click open disc

Actual results:
Can not find the device

Expected results:
DVD drive is found

Additional info:
Comment 1 Andreas Bierfert 2006-04-07 02:45:47 EDT

*** This bug has been marked as a duplicate of 183735 ***
Comment 2 Jacek Pliszka 2006-04-07 03:04:33 EDT
Tried with wine settings: NT4 and W2K, neither works. DVD I tried is unencrypted.
Comment 3 Andreas Bierfert 2006-04-07 03:12:58 EDT
Take a look at bug 183735. This is because mounts are handled automatically on
FC5 now.
Comment 4 Jacek Pliszka 2006-04-07 16:24:21 EDT
Well, It does not seem to be a duplicate.

I did umount the DVD, put the line in /etc/fstab, mounted manually and wine
still did not see the drive in DVD Decryptor/DVD Shrink !!!

The drive is seen in other places. In fact

wine DVDShrink D:

does see the data on the drive!

So it is not because of missing /etc/fstab line ...
Comment 5 Andreas Bierfert 2006-04-08 03:05:29 EDT
Well then it might be an upstream bug. Did you run winecfg after the change to
fstab. Try that and if that does not help please report it upstream at winehq...
Comment 6 Jacek Pliszka 2006-04-08 04:08:10 EDT
I did run wincfg and it did not help. So I will report it at winehq.

Note You need to log in before you can comment on or make changes to this bug.