Bug 188225 - Dejavu-fonts 2.4 broke my tcl application's font
Dejavu-fonts 2.4 broke my tcl application's font
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dejavu-fonts (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nicolas Mailhot
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-07 04:30 EDT by Maxim Britov
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-07 07:16:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Maxim Britov 2006-04-07 04:30:25 EDT
Description of problem:
I use tkabber (tcl/tk application) for xmpp messaging.
Updateing to latest package 2.4.0 and 2.4.1 (now) broke tkabber interface.
All in tkabber interface looks "l i k e  t h i s ".
For interface i use in tkabber config:
set font "-misc-dejavu sans-medium-r-normal-*-11-*-*-*-*-*-iso10646-1"
option add *font "-misc-dejavu sans-medium-r-normal-*-11-*-*-*-*-*-iso8859-1"
userDefault
and it works fine with 2.3 package from fc5.

Version-Release number of selected component (if applicable):
dejavu-fonts-2.4.1-2.fc6
dejavu-fonts-fontconfig-2.4.1-2.fc6


How reproducible:


Steps to Reproduce:
1.update dejavu-fonts to 2.4.1
2.run tkabber
3.look broken interface :(
  
Actual results:
Broken interface

Expected results:


Additional info:
Comment 1 Nicolas Mailhot 2006-04-07 07:16:21 EDT
DejaVu is not intended to be used with the old legacy core font system. Dejavu
is a font with wide coverage and modern truetype features and will probably
break the old backend in several strange and wonderful ways. Unless you can
reproduce this with a fontconfig app, I'll mark this as NOTABUG.

1. we intentionnaly do not register dejavu in XFS
2. fonts actually registered in XFS are not intended to be used with iso10646-1
encoding and are broken up in many encoding-specific files
3. any sane internationalised GUI app switched to fontconfig long ago (why am I
not surprised it's not the case for tcl/tk?)

Note You need to log in before you can comment on or make changes to this bug.