Bug 188230 - STAC92xx Analogue (Intel Corporation 82801G (ICH7 Family)) gives no sound
STAC92xx Analogue (Intel Corporation 82801G (ICH7 Family)) gives no sound
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: system-config-soundcard (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-07 06:06 EDT by Wes Armour
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-07 08:25:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
scsound.log (7.41 KB, text/plain)
2006-04-07 08:09 EDT, Wes Armour
no flags Details

  None (edit)
Description Wes Armour 2006-04-07 06:06:35 EDT
Description of problem:

The system-config-soundcard utility tells me I have a STAC92xx sound card.
I play the test sound and hear nothing.
I have used alsamixer to unmute everything,
I suspect it is a problem with the snd_hda_intel kernel module on the x86_64
platform.

lspci gives:

$ /sbin/lspci 
00:00.0 Host bridge: Intel Corporation 955X Memory Controller Hub
00:01.0 PCI bridge: Intel Corporation 955X PCI Express Graphics Port
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition
Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1
(rev 01)
00:1c.4 PCI bridge: Intel Corporation 82801GR/GH/GHM (ICH7 Family) PCI Express
Port 5 (rev 01)
00:1c.5 PCI bridge: Intel Corporation 82801GR/GH/GHM (ICH7 Family) PCI Express
Port 6 (rev 01)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI
Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface
Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller
(rev 01)
00:1f.2 SATA controller: Intel Corporation 82801GR/GH (ICH7 Family) Serial ATA
Storage Controllers cc=AHCI (rev 01)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 01)
01:00.0 VGA compatible controller: ATI Technologies Inc RV370 5B64 [FireGL V3100
(PCIE)] (rev 80)
01:00.1 Display controller: ATI Technologies Inc RV370 5B64 [FireGL V3100
(PCIE)] (Secondary) (rev 80)
04:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5751 Gigabit
Ethernet PCI Express (rev 01)

lsmod gives:

]$ /sbin/lsmod 
Module                  Size  Used by
nls_utf8               35265  2 
cifs                  245153  2 
radeon                140513  0 
drm                   117097  1 radeon
nfsd                  286249  17 
exportfs               38977  1 nfsd
ppdev                  42441  0 
hidp                   83137  2 
nfs                   251289  3 
lockd                  96977  3 nfsd,nfs
nfs_acl                36801  2 nfsd,nfs
rfcomm                104801  0 
l2cap                  91585  10 hidp,rfcomm
bluetooth             116932  3 hidp,rfcomm,l2cap
sunrpc                192137  13 nfsd,nfs,lockd,nfs_acl
ipv6                  398689  20 
ip_conntrack_netbios_ns    36033  0 
ipt_REJECT             38977  1 
xt_state               35265  14 
ip_conntrack           92669  2 ip_conntrack_netbios_ns,xt_state
nfnetlink              40073  1 ip_conntrack
xt_tcpudp              36545  16 
iptable_filter         36289  1 
ip_tables              48385  1 iptable_filter
x_tables               48201  4 ipt_REJECT,xt_state,xt_tcpudp,ip_tables
raid1                  54977  1 
video                  50505  0 
button                 40545  0 
battery                43337  0 
ac                     38473  0 
lp                     47633  0 
parport_pc             62697  1 
parport                74061  3 ppdev,lp,parport_pc
floppy                100617  0 
nvram                  42441  0 
ehci_hcd               65229  0 
uhci_hcd               65505  0 
sg                     69097  0 
snd_hda_intel          52185  1 
snd_hda_codec         175041  1 snd_hda_intel
snd_seq_dummy          37061  0 
snd_seq_oss            66241  0 
snd_seq_midi_event     41025  1 snd_seq_oss
snd_seq                89825  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device         42833  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            85457  0 
snd_mixer_oss          50881  1 snd_pcm_oss
snd_pcm               126409  3 snd_hda_intel,snd_hda_codec,snd_pcm_oss
i2c_i801               42581  0 
snd_timer              59465  2 snd_seq,snd_pcm
hw_random              39145  0 
snd                    97129  11 snd_hda_intel,snd_hda_codec,snd_seq_oss,snd_seq
                                                                               
                                                                               
                     ,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore              44129  1 snd
snd_page_alloc         44497  2 snd_hda_intel,snd_pcm
tg3                   131781  0 
i2c_core               57409  1 i2c_i801
dm_snapshot            48657  0 
dm_zero                35137  0 
dm_mirror              54337  0 
dm_mod                 89745  6 dm_snapshot,dm_zero,dm_mirror
raid5                  58049  2 
xor                    38609  1 raid5
ext3                  164176  3 
jbd                    93545  1 ext3
ahci                   47045  11 
libata                 93913  1 ahci
sd_mod                 50753  14 
scsi_mod              181137  4 sg,ahci,libata,sd_mod

Version-Release number of selected component (if applicable):

$ rpm -qa system-config-soundcard
system-config-soundcard-1.2.16-2


How reproducible:

Always

Steps to Reproduce:
1. As above (or just install core 5).
2.
3.
  
Actual results:

No sound :(

Expected results:

Music!

Additional info:

It would be nice if I could add mp3 support easily!

Thanks :)
Comment 1 Martin Stransky 2006-04-07 06:59:58 EDT
please attach your /root/scsound.log
Comment 2 Martin Stransky 2006-04-07 07:11:44 EDT
if you have default ALSA drivers (11rc2) you can check install the new ones,
how-to is here: http://people.redhat.com/stransky/alsa

how-to for mp3 support is here: http://www.fedorafaq.org/#mp3
Comment 3 Wes Armour 2006-04-07 08:09:47 EDT
Created attachment 127453 [details]
scsound.log
Comment 4 Wes Armour 2006-04-07 08:12:41 EDT
I installed the alsa-driver-1.0.11rc4.FC5.tar.bz2

That went fine,

I rebuilt the alsa-utils and alsa-lib rpms and that was ok.

I tried to install them and got:

[root@pc007 x86_64]# rpm -Uvh alsa-utils-1.0.11-1.rc4.FC5.test.x86_64.rpm
alsa-lib-1.0.11-1.rc4.FC5.test.x86_64.rpm 
Preparing...                ########################################### [100%]
        package alsa-lib-1.0.11-3.rc2.2 (which is newer than
alsa-lib-1.0.11-1.rc4.FC5.test) is already installed
        package alsa-utils-1.0.11-4.rc2 (which is newer than
alsa-utils-1.0.11-1.rc4.FC5.test) is already installed
        file /etc/alsa/alsa.conf from install of alsa-lib-1.0.11-1.rc4.FC5.test
conflicts with file from package alsa-lib-1.0.11-3.rc2.2
        file /etc/alsa/cards/ATIIXP-SPDMA.conf from install of
alsa-lib-1.0.11-1.rc4.FC5.test conflicts with file from package
alsa-lib-1.0.11-3.rc2.2
        file /etc/alsa/cards/ATIIXP.conf from install of
alsa-lib-1.0.11-1.rc4.FC5.test conflicts with file from package
alsa-lib-1.0.11-3.rc2.2
        file /etc/alsa/cards/Aureon51.conf from install of
alsa-lib-1.0.11-1.rc4.FC5.test conflicts with file from package
alsa-lib-1.0.11-3.rc2.2
        file /etc/alsa/cards/Aureon71.conf from install of
alsa-lib-1.0.11-1.rc4.FC5.test conflicts with file from package
alsa-lib-1.0.11-3.rc2.2
        file /etc/alsa/cards/CMI8738-MC6.conf from install of
alsa-lib-1.0.11-1.rc4.FC5.test conflicts with file from package
alsa-lib-1.0.11-3.rc2.2
        file /etc/alsa/cards/CMI8738-MC8.conf from install of
alsa-lib-1.0.11-1.rc4.FC5.test conflicts with file from package
alsa-lib-1.0.11-3.rc2.2
        file /etc/alsa/cards/ICE1712.conf from install of
alsa-lib-1.0.11-1.rc4.FC5.test conflicts with file from package
alsa-lib-1.0.11-3.rc2.2
        file /etc/alsa/cards/ICH.conf from install of
alsa-lib-1.0.11-1.rc4.FC5.test conflicts with file from package
alsa-lib-1.0.11-3.rc2.2
        file /etc/alsa/cards/ICH4.conf from install of
alsa-lib-1.0.11-1.rc4.FC5.test conflicts with file from package
alsa-lib-1.0.11-3.rc2.2
        file /etc/alsa/cards/NFORCE.conf from install of
alsa-lib-1.0.11-1.rc4.FC5.test conflicts with file from package
alsa-lib-1.0.11-3.rc2.2
        file /etc/alsa/cards/VIA8233.conf from install of
alsa-lib-1.0.11-1.rc4.FC5.test conflicts with file from package
alsa-lib-1.0.11-3.rc2.2
        file /etc/alsa/cards/VIA8233A.conf from install of
alsa-lib-1.0.11-1.rc4.FC5.test conflicts with file from package
alsa-lib-1.0.11-3.rc2.2
        file /etc/alsa/cards/VIA8237.conf from install of
alsa-lib-1.0.11-1.rc4.FC5.test conflicts with file from package
alsa-lib-1.0.11-3.rc2.2
        file /etc/alsa/cards/aliases.conf from install of
alsa-lib-1.0.11-1.rc4.FC5.test conflicts with file from package
alsa-lib-1.0.11-3.rc2.2
        file /etc/alsa/pcm/dmix.conf from install of
alsa-lib-1.0.11-1.rc4.FC5.test conflicts with file from package
alsa-lib-1.0.11-3.rc2.2
        file /etc/alsa/pcm/dsnoop.conf from install of
alsa-lib-1.0.11-1.rc4.FC5.test conflicts with file from package
alsa-lib-1.0.11-3.rc2.2
[root@pc007 x86_64]# rpm -i alsa-utils-1.0.11-1.rc4.FC5.test.x86_64.rpm
alsa-lib-1.0.11-1.rc4.FC5.test.x86_64.rpm 
        package alsa-lib-1.0.11-3.rc2.2 (which is newer than
alsa-lib-1.0.11-1.rc4.FC5.test) is already installed
        package alsa-utils-1.0.11-4.rc2 (which is newer than
alsa-utils-1.0.11-1.rc4.FC5.test) is already installed
        file /etc/alsa/alsa.conf from install of alsa-lib-1.0.11-1.rc4.FC5.test
conflicts with file from package alsa-lib-1.0.11-3.rc2.2
        file /etc/alsa/cards/ATIIXP-SPDMA.conf from install of
alsa-lib-1.0.11-1.rc4.FC5.test conflicts with file from package
alsa-lib-1.0.11-3.rc2.2
        file /etc/alsa/cards/ATIIXP.conf from install of
alsa-lib-1.0.11-1.rc4.FC5.test conflicts with file from package
alsa-lib-1.0.11-3.rc2.2
        file /etc/alsa/cards/Aureon51.conf from install of
alsa-lib-1.0.11-1.rc4.FC5.test conflicts with file from package
alsa-lib-1.0.11-3.rc2.2
        file /etc/alsa/cards/Aureon71.conf from install of
alsa-lib-1.0.11-1.rc4.FC5.test conflicts with file from package
alsa-lib-1.0.11-3.rc2.2
        file /etc/alsa/cards/CMI8738-MC6.conf from install of
alsa-lib-1.0.11-1.rc4.FC5.test conflicts with file from package
alsa-lib-1.0.11-3.rc2.2
        file /etc/alsa/cards/CMI8738-MC8.conf from install of
alsa-lib-1.0.11-1.rc4.FC5.test conflicts with file from package
alsa-lib-1.0.11-3.rc2.2
        file /etc/alsa/cards/ICE1712.conf from install of
alsa-lib-1.0.11-1.rc4.FC5.test conflicts with file from package
alsa-lib-1.0.11-3.rc2.2
        file /etc/alsa/cards/ICH.conf from install of
alsa-lib-1.0.11-1.rc4.FC5.test conflicts with file from package
alsa-lib-1.0.11-3.rc2.2
        file /etc/alsa/cards/ICH4.conf from install of
alsa-lib-1.0.11-1.rc4.FC5.test conflicts with file from package
alsa-lib-1.0.11-3.rc2.2
        file /etc/alsa/cards/NFORCE.conf from install of
alsa-lib-1.0.11-1.rc4.FC5.test conflicts with file from package
alsa-lib-1.0.11-3.rc2.2
        file /etc/alsa/cards/VIA8233.conf from install of
alsa-lib-1.0.11-1.rc4.FC5.test conflicts with file from package
alsa-lib-1.0.11-3.rc2.2
        file /etc/alsa/cards/VIA8233A.conf from install of
alsa-lib-1.0.11-1.rc4.FC5.test conflicts with file from package
alsa-lib-1.0.11-3.rc2.2
        file /etc/alsa/cards/VIA8237.conf from install of
alsa-lib-1.0.11-1.rc4.FC5.test conflicts with file from package
alsa-lib-1.0.11-3.rc2.2
        file /etc/alsa/cards/aliases.conf from install of
alsa-lib-1.0.11-1.rc4.FC5.test conflicts with file from package
alsa-lib-1.0.11-3.rc2.2
        file /etc/alsa/pcm/dmix.conf from install of
alsa-lib-1.0.11-1.rc4.FC5.test conflicts with file from package
alsa-lib-1.0.11-3.rc2.2
        file /etc/alsa/pcm/dsnoop.conf from install of
alsa-lib-1.0.11-1.rc4.FC5.test conflicts with file from package
alsa-lib-1.0.11-3.rc2.2
        file /lib64/libasound.so.2.0.0 from install of
alsa-lib-1.0.11-1.rc4.FC5.test conflicts with file from package
alsa-lib-1.0.11-3.rc2.2
        file /usr/bin/alsalisp from install of alsa-lib-1.0.11-1.rc4.FC5.test
conflicts with file from package alsa-lib-1.0.11-3.rc2.2
        file /usr/bin/aserver from install of alsa-lib-1.0.11-1.rc4.FC5.test
conflicts with file from package alsa-lib-1.0.11-3.rc2.2
        file /usr/lib64/alsa-lib/smixer/smixer-ac97.a from install of
alsa-lib-1.0.11-1.rc4.FC5.test conflicts with file from package
alsa-lib-1.0.11-3.rc2.2
        file /usr/lib64/alsa-lib/smixer/smixer-ac97.so from install of
alsa-lib-1.0.11-1.rc4.FC5.test conflicts with file from package
alsa-lib-1.0.11-3.rc2.2
        file /usr/lib64/alsa-lib/smixer/smixer-hda.a from install of
alsa-lib-1.0.11-1.rc4.FC5.test conflicts with file from package
alsa-lib-1.0.11-3.rc2.2
        file /usr/lib64/alsa-lib/smixer/smixer-hda.so from install of
alsa-lib-1.0.11-1.rc4.FC5.test conflicts with file from package
alsa-lib-1.0.11-3.rc2.2
        file /usr/lib64/alsa-lib/smixer/smixer-sbase.a from install of
alsa-lib-1.0.11-1.rc4.FC5.test conflicts with file from package
alsa-lib-1.0.11-3.rc2.2
        file /usr/lib64/alsa-lib/smixer/smixer-sbase.so from install of
alsa-lib-1.0.11-1.rc4.FC5.test conflicts with file from package
alsa-lib-1.0.11-3.rc2.2
        file /sbin/alsactl from install of alsa-utils-1.0.11-1.rc4.FC5.test
conflicts with file from package alsa-utils-1.0.11-4.rc2
        file /usr/bin/aconnect from install of alsa-utils-1.0.11-1.rc4.FC5.test
conflicts with file from package alsa-utils-1.0.11-4.rc2
        file /usr/bin/alsamixer from install of alsa-utils-1.0.11-1.rc4.FC5.test
conflicts with file from package alsa-utils-1.0.11-4.rc2
        file /usr/bin/amidi from install of alsa-utils-1.0.11-1.rc4.FC5.test
conflicts with file from package alsa-utils-1.0.11-4.rc2
        file /usr/bin/amixer from install of alsa-utils-1.0.11-1.rc4.FC5.test
conflicts with file from package alsa-utils-1.0.11-4.rc2
        file /usr/bin/aplay from install of alsa-utils-1.0.11-1.rc4.FC5.test
conflicts with file from package alsa-utils-1.0.11-4.rc2
        file /usr/bin/aplaymidi from install of alsa-utils-1.0.11-1.rc4.FC5.test
conflicts with file from package alsa-utils-1.0.11-4.rc2
        file /usr/bin/arecordmidi from install of
alsa-utils-1.0.11-1.rc4.FC5.test conflicts with file from package
alsa-utils-1.0.11-4.rc2
        file /usr/bin/aseqdump from install of alsa-utils-1.0.11-1.rc4.FC5.test
conflicts with file from package alsa-utils-1.0.11-4.rc2
        file /usr/bin/aseqnet from install of alsa-utils-1.0.11-1.rc4.FC5.test
conflicts with file from package alsa-utils-1.0.11-4.rc2
        file /usr/bin/iecset from install of alsa-utils-1.0.11-1.rc4.FC5.test
conflicts with file from package alsa-utils-1.0.11-4.rc2
        file /usr/bin/speaker-test from install of
alsa-utils-1.0.11-1.rc4.FC5.test conflicts with file from package
alsa-utils-1.0.11-4.rc2
        file /usr/share/man/man1/aplay.1.gz from install of
alsa-utils-1.0.11-1.rc4.FC5.test conflicts with file from package
alsa-utils-1.0.11-4.rc2
        file /usr/share/man/man1/speaker-test.1.gz from install of
alsa-utils-1.0.11-1.rc4.FC5.test conflicts with file from package
alsa-utils-1.0.11-4.rc2


Any suggestions???

Thanks,

Wes.
Comment 5 Martin Stransky 2006-04-07 08:22:33 EDT
Uninstall the old (default) alsa-utils/alsa-lib packages first....
Comment 6 Wes Armour 2006-04-07 08:25:17 EDT
Agggghhhhhh ok I'm a bit slow today :)

I rebooted anyhow and now I get sound!!! :)

Thanks!!!

Note You need to log in before you can comment on or make changes to this bug.