Bug 188331 - up2date not functioning
up2date not functioning
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bret McMillan
Beth Nackashi
Depends On:
  Show dependency treegraph
Reported: 2006-04-07 19:33 EDT by Chris Singleton
Modified: 2008-10-15 11:18 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-05-31 10:32:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Chris Singleton 2006-04-07 19:33:38 EDT
Description of problem:
Cannot use up2date

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.  Attempt to connect using up2date with the flashing !
2.  When the system connects, it states I need a new version of up2date.  I have
4.4.5-1, but it states I need 4.4.67-4
3.  When  I attempt to load up2date 4.4.67-4 from the channels menu, it states
that I need the up2date packeage that is required by up2date 4.4.67-4
4.  The only up2date package I can locate is 4.4.67-4, which I can't load
because it requires the original up2date, which I cannot install.
Actual results:
Not able to update the system.  I am registered with rhn and have activated my

Expected results:
Ability to automatically update

Additional info:
Running RHEL WS 4 on a Dell Precision 380n
Comment 1 Chris Singleton 2006-05-24 22:23:11 EDT
I recieve this message when I attempt to connect to the red hat server:

Error Message:
    Please run rhn_register (or up2date --register on Red Hat Enterprise Linux 3
or later)
as root on this client
Error Class Code: 9
Error Class Info: Invalid System Credentials.
     An error has occurred while processing your request. If this problem
     persists please enter a bug report at bugzilla.redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.

But I am unable to download and install the new up2date, it says I am missing
some dependencies (up2date-gnome) which I also cannot install.
Comment 2 Chris Singleton 2006-05-31 10:11:12 EDT
Is there anyone here???
Comment 3 Bret McMillan 2006-05-31 10:32:43 EDT
I'm having trouble understanding how you're seeing the issue in comment #1 if
the problem in comment #2 exists.  I'm going to presume comment #2 is the main
existing problem at the moment.

Right now, RHN is not recognizing your /etc/sysconfig/rhn/systemid file as valid

Please re-register with RHN, either via 'up2date --register', or using rhnreg_ks.

That should give you a working /etc/sysconfig/rhn/systemid file.

Be advised that you may need to delete your original profile on
https://rhn.redhat.com/ to free up your entitlements for use with you new profile.

If you still have errors after that, please reopen the bug.

Note You need to log in before you can comment on or make changes to this bug.