Bug 188355 - Pirut does not install Languages, and/or does not correctly track installed languages
Pirut does not install Languages, and/or does not correctly track installed l...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
: 137947 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-08 07:09 EDT by Jonathan Underwood
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-09 15:35:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Underwood 2006-04-08 07:09:31 EDT
Description of problem:
Selecting a language to be installed under pirut does not work. At install time,
I selected British support, but when I run pirut now, it shows British support
as not installed. And subsequently if I select British support (under
Languages), and then click apply, Pirut claims "No software selected for
installation or removal" 

Version-Release number of selected component (if applicable):
pirut-1.0.1-1

How reproducible:
Every time

Steps to Reproduce:
1.Run pirut
2.Note that any installed languages are not shown
3.Select a language, click apply
  
Actual results:
Pirut claims "No software selected for installation or removal" 

Expected results:
Pirut installs selected language support

Additional info:
Comment 1 Jeremy Katz 2006-04-12 13:59:55 EDT
Hrmm.  This is because the only thing in British Support is kde-i18n-British,
which will only get installed if you have kdelibs installed. 

*sigh*  the conditional stuff like this just makes the UI so awful :(
Comment 2 John Thacker 2006-04-21 21:19:40 EDT
*** Bug 137947 has been marked as a duplicate of this bug. ***
Comment 3 Jeremy Katz 2007-04-09 15:35:57 EDT
This should be better for Fedora 7

Note You need to log in before you can comment on or make changes to this bug.