Bug 188365 - Bonsai needs some care
Bonsai needs some care
Status: CLOSED CANTFIX
Product: Fedora Infrastructure
Classification: Retired
Component: cvs (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike McGrath
Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-08 11:07 EDT by Michael Schwendt
Modified: 2008-11-08 06:16 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-08 06:16:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2006-04-08 11:07:13 EDT
http://cvs.fedora.redhat.com/bonsai/toplevel.cgi?treeid=extras

Software error:

Can't locate data/treeconfig.pl in @INC (@INC contains:
/usr/lib64/perl5/5.8.5/x86_64-linux-thread-multi /usr/lib/perl5/5.8.5
/usr/lib64/perl5/site_perl/5.8.5/x86_64-linux-thread-multi
/usr/lib64/perl5/site_perl/5.8.4/x86_64-linux-thread-multi
/usr/lib64/perl5/site_perl/5.8.3/x86_64-linux-thread-multi
/usr/lib64/perl5/site_perl/5.8.2/x86_64-linux-thread-multi
/usr/lib64/perl5/site_perl/5.8.1/x86_64-linux-thread-multi
/usr/lib64/perl5/site_perl/5.8.0/x86_64-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4
/usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2
/usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0
/usr/lib/perl5/site_perl
/usr/lib64/perl5/vendor_perl/5.8.5/x86_64-linux-thread-multi
/usr/lib64/perl5/vendor_perl/5.8.4/x86_64-linux-thread-multi
/usr/lib64/perl5/vendor_perl/5.8.3/x86_64-linux-thread-multi
/usr/lib64/perl5/vendor_perl/5.8.2/x86_64-linux-thread-multi
/usr/lib64/perl5/vendor_perl/5.8.1/x86_64-linux-thread-multi
/usr/lib64/perl5/vendor_perl/5.8.0/x86_64-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl/5.8.4
/usr/lib/perl5/vendor_perl/5.8.3 /usr/lib/perl5/vendor_perl/5.8.2
/usr/lib/perl5/vendor_perl/5.8.1 /usr/lib/perl5/vendor_perl/5.8.0
/usr/lib/perl5/vendor_perl .) at globals.pl line 533.

For help, please send mail to the webmaster (root@localhost), giving this error
message and the time and date of the error.
Comment 1 Mike McGrath 2006-07-25 22:12:15 EDT
I've fixed one problem but run into another.  This is my first work with this
particular app.  Do you happen to know if it was ever properly running?  Right
now its just kind of in limbo.
Comment 2 Mike McGrath 2006-07-25 22:20:37 EDT
Problem solved (I think).  Looks like the packager didn't mark configs as such
and when this was updated (in March?) some files got moved.  Give it a look and
if its working please let me know.
Comment 3 Michael Schwendt 2006-07-26 04:38:02 EDT
Well, now the start-page loads fine. But should it be able to do
anything beyond that? Like querying the CVS repository? Nothing seems
to work.

[...]

http://cvs.fedora.redhat.com/bonsai/countcheckins.cgi?&treeid=extras

Empty statistics!

[...]

http://cvs.fedora.redhat.com/bonsai/editwhiteboard.cgi?&treeid=extras

Software error:

Couldn't create `data/extras/whiteboard': Permission denied at globals.pl line 311.

[...]

http://cvs.fedora.redhat.com/tinderbox//showbuilds.cgi

Not Found

The requested URL /tinderbox//showbuilds.cgi was not found on this server.

[...]

http://cvs.fedora.redhat.com/bonsai/toplevel.cgi?treeid=extras&batchid=

Software error:

Invalid format for batchid.

For help, please send mail to the webmaster (root@localhost), giving this error
message and the time and date of the error.
Software error:

[Wed Jul 26 01:46:02 2006] toplevel.cgi: Invalid format for batchid.
Compilation failed in require at /var/www/bonsai/toplevel.cgi line 23.

For help, please send mail to the webmaster (root@localhost), giving this error
message and the time and date of the error. 

Comment 4 Rich Megginson 2007-10-19 13:00:39 EDT
http://cvs.fedoraproject.org/bonsai/cvsqueryform.cgi?cvsroot=&module=

Gives, at the bottom of the page:
Software error:

install_driver(mysql) failed: Can't locate DBD/mysql.pm in @INC (@INC contains:
/usr/lib64/perl5/5.8.5/x86_64-linux-thread-multi /usr/lib/perl5/5.8.5
/usr/lib64/perl5/site_perl/5.8.5/x86_64-linux-thread-multi
/usr/lib64/perl5/site_perl/5.8.4/x86_64-linux-thread-multi
/usr/lib64/perl5/site_perl/5.8.3/x86_64-linux-thread-multi
/usr/lib64/perl5/site_perl/5.8.2/x86_64-linux-thread-multi
/usr/lib64/perl5/site_perl/5.8.1/x86_64-linux-thread-multi
/usr/lib64/perl5/site_perl/5.8.0/x86_64-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4
/usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2
/usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0
/usr/lib/perl5/site_perl
/usr/lib64/perl5/vendor_perl/5.8.5/x86_64-linux-thread-multi
/usr/lib64/perl5/vendor_perl/5.8.4/x86_64-linux-thread-multi
/usr/lib64/perl5/vendor_perl/5.8.3/x86_64-linux-thread-multi
/usr/lib64/perl5/vendor_perl/5.8.2/x86_64-linux-thread-multi
/usr/lib64/perl5/vendor_perl/5.8.1/x86_64-linux-thread-multi
/usr/lib64/perl5/vendor_perl/5.8.0/x86_64-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl/5.8.4
/usr/lib/perl5/vendor_perl/5.8.3 /usr/lib/perl5/vendor_perl/5.8.2
/usr/lib/perl5/vendor_perl/5.8.1 /usr/lib/perl5/vendor_perl/5.8.0
/usr/lib/perl5/vendor_perl .) at (eval 4) line 3, <CACHE> line 3.
Perhaps the DBD::mysql perl module hasn't been fully installed,
or perhaps the capitalisation of 'mysql' isn't right.
Available drivers: ExampleP, Proxy, Sponge.
 at globals.pl line 114

For help, please send mail to the webmaster (root@localhost), giving this error
message and the time and date of the error. 
Comment 5 Rich Megginson 2007-10-19 13:01:41 EDT
If I actually attempt to run a query:

Software error:

install_driver(mysql) failed: Can't locate DBD/mysql.pm in @INC (@INC contains:
/usr/lib64/perl5/5.8.5/x86_64-linux-thread-multi /usr/lib/perl5/5.8.5
/usr/lib64/perl5/site_perl/5.8.5/x86_64-linux-thread-multi
/usr/lib64/perl5/site_perl/5.8.4/x86_64-linux-thread-multi
/usr/lib64/perl5/site_perl/5.8.3/x86_64-linux-thread-multi
/usr/lib64/perl5/site_perl/5.8.2/x86_64-linux-thread-multi
/usr/lib64/perl5/site_perl/5.8.1/x86_64-linux-thread-multi
/usr/lib64/perl5/site_perl/5.8.0/x86_64-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4
/usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2
/usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0
/usr/lib/perl5/site_perl
/usr/lib64/perl5/vendor_perl/5.8.5/x86_64-linux-thread-multi
/usr/lib64/perl5/vendor_perl/5.8.4/x86_64-linux-thread-multi
/usr/lib64/perl5/vendor_perl/5.8.3/x86_64-linux-thread-multi
/usr/lib64/perl5/vendor_perl/5.8.2/x86_64-linux-thread-multi
/usr/lib64/perl5/vendor_perl/5.8.1/x86_64-linux-thread-multi
/usr/lib64/perl5/vendor_perl/5.8.0/x86_64-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl/5.8.4
/usr/lib/perl5/vendor_perl/5.8.3 /usr/lib/perl5/vendor_perl/5.8.2
/usr/lib/perl5/vendor_perl/5.8.1 /usr/lib/perl5/vendor_perl/5.8.0
/usr/lib/perl5/vendor_perl .) at (eval 4) line 3.
Perhaps the DBD::mysql perl module hasn't been fully installed,
or perhaps the capitalisation of 'mysql' isn't right.
Available drivers: ExampleP, Proxy, Sponge.
 at globals.pl line 114

Comment 6 Rich Megginson 2007-10-19 13:04:30 EDT
cvs.fedoraproject.org is _the_ SCM for Fedora Directory Server.  As such, we
really, really depend on tools such as bonsai and lxr to help manage the source
code.  If additional people are needed to work on these tools, I'll see what I
can do.
Comment 7 Michael Schwendt 2008-11-08 06:16:59 EST
Someone with interest in this please clone this ticket or reopen
an own one.

Note You need to log in before you can comment on or make changes to this bug.