Bug 188398 - scim.x86_64 should require scim-libs.i386
scim.x86_64 should require scim-libs.i386
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
5
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
Bill Nottingham
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-08 21:47 EDT by CA G Rajesh
Modified: 2014-03-16 22:59 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-06 00:20:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description CA G Rajesh 2006-04-08 21:47:59 EDT
Description of problem:
I am using English(India) locale and have installed Tamil (ta_IN) too. I have
made all the configurational formalities needed to run scim as specified in
release notes.
Scim works fine in all gtk applications but not in openoffice. In fact, once
openoffice is up, scim does not work, I mean get activated, at all.
Using Tamil input in OO.o is vital, though we generally use English for all
other purposes - I mean, locale changing is possible.


Version-Release number of selected component (if applicable):
scim-1.4.4-9.1.fc5



How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Mayank Jain 2006-04-10 03:05:50 EDT
Hi,

I was able to use tamil input in OO Writer

Steps to follow :-
$ scim
$ export GTK_IM_MODULE="scim"
$ oowriter

Now activate scim > tamil input > type in tamil.

I have following versions of packages installed
openoffice.org-writer-2.0.2-5.2.2
scim-1.4.4-13
scim-m17n-0.2.0-3
scim-libs-1.4.4-13
scim-tables-additional-0.5.6-4
scim-qtimm-0.9.4-3
scim-tables-0.5.6-4
fonts-tamil-1.10-2.1
m17n-db-tamil-1.3.3-2



Comment 2 CA G Rajesh 2006-04-11 05:58:46 EDT
I tried to open Openoffice writer with the command, GTK_IM_MODULE=xim oowriter.
Now, only difference is I could make keyboard work - I mean the toggling between
english(us) and tamilnet99 keyboards. 
But Input did not work. BTW, except for the adjustments required to be made in
release notes regarding ".xinput.d", is there anything I have missed? 
When I upgraded from fc4, I did not format /home to save data. I thought whether
could this be a problem. But when I created different user, things did not work
there too. When people at redhat could use scim (tamil) in OO.o, what prevents
me to use - hmm ... this thing is really driving me crazy!!!
Comment 3 Mayank Jain 2006-04-11 10:35:41 EDT
Hi,

Did you tried with 
export GTK_IM_MODULE="scim"
Comment 4 CA G Rajesh 2006-04-11 11:17:25 EDT
Yes, majain. 
That is default setting, no? In this case, keyboard does not work/activate at
all in OO.o. In case of, GTK_IM_MODULLE=xim, keyboard works but no input in
OO.o. Beware in previous case, I could input in all gtk applications, but not in
later case. 
BTW, I forgot to say one important thing. I am using fc5_64. When I saw yumex, I
find that scim, etc are 64bit softwares, but OO.o is 32bit. Could this be a
cause for my problem?
Comment 5 CA G Rajesh 2006-04-11 11:21:56 EDT
Sorry, I forgot one more thing:
When I type oowriter, I get the following message:

(process:2732): Gdk-WARNING **: locale not supported by Xlib
(process:2732): Gdk-WARNING **: cannot set locale modifiers

Any idea? I tried opening OO.o with both English(India) and English(USA)
language  settings, but the above message is displayed in both. Scim
documentation says setting up locale is important. Do I miss anywhere?

Comment 6 Jens Petersen 2006-04-11 23:36:34 EDT
(In reply to comment #4)
> BTW, I forgot to say one important thing. I am using fc5_64. When I saw yumex, I
> find that scim, etc are 64bit softwares, but OO.o is 32bit. Could this be a
> cause for my problem?

Ah yes, of course - I fell into the same trap myself when testing...

Do you have scim-libs.i386 installed?  With that everything should
work I think.  Sorry for the confusion.

(In reply to comment #5)
> (process:2732): Gdk-WARNING **: locale not supported by Xlib
> (process:2732): Gdk-WARNING **: cannot set locale modifiers

That is just a warning from libX to say that it doesn't know the
locale you're using (en_IN?): it is not critical to the problem
I think, but it is better to avoid such locale.
Comment 7 CA G Rajesh 2006-04-27 07:33:33 EDT
In future, please ensure that 32bit scim-libs and m17n-libs(if needed) are
automatically installed in case of 64bit systems in order to avoid such
problems. Thanks for everything.
Comment 8 Jens Petersen 2006-04-27 22:23:52 EDT
Yes thanks, you're right I have also been thinking to make scim.x86_64
require scim-libs.i386 to avoid this kind of problem.  
Comment 9 Warren Togami 2006-04-27 23:58:30 EDT
At issue here is that gtk2 doesn't have any way of gracefully handling this
situation in an informative way.

Currently we have no way with rpm of one arch to require a package a different arch.

Requires: %{_prefix}/lib/gtk-2.0/immodules/im-scim.so
This proposed line would technically work, but it would cause problems because
64bit archs would no longer be dep consistent on their own.  AFAIK, we have no
other packages that do this currently.  Please bring this to fedora-maintainers
for discussion, and maybe they can think of a better solution
Comment 11 Jens Petersen 2006-07-05 07:22:16 EDT
This is kind of related to the multilib request,
but is there some way to ensure that scim-libs.{i386,x86_64}
both get installed together on x86_64 (ie both or neither).
Ditto for scim-bridge-gtkimm.

I'm still tempted to add:
  Requires: %{_prefix}/lib/gtk-2.0/immodules/im-scim.so
to scim.x86_64 and similarly for scim-bridge.x86_64...
Comment 12 Bill Nottingham 2006-07-05 14:00:15 EDT
CC'ing one of the yum/anaconda/etc people.
Comment 13 Leon Ho 2006-08-28 01:26:12 EDT
This is related to how we handle multilib for OOo. Jeremy, do you have any
comments on handling this siutation in anaconda situation?
Comment 14 Jens Petersen 2006-08-28 04:42:35 EDT
The original request still holds, but I think anaconda handles this ok for fc5
installs and upgrades, so maybe it can be closed.

(For fc6 oo.o exists for x86_64 and we really want scim-bridge-gtkimm.i386
instead, but there are other tickets open for that.)
Comment 15 Jeremy Katz 2006-09-06 00:20:41 EDT
Yeah, this should be handled better for FC6

Note You need to log in before you can comment on or make changes to this bug.