Bug 188415 - CVS extra dependncy on tcsh
Summary: CVS extra dependncy on tcsh
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: cvs   
(Show other bugs)
Version: 5
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-04-09 10:09 UTC by David Nečas
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-25 07:53:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Nečas 2006-04-09 10:09:36 UTC
Description of problem:
The cvs package depends on tcsh and this dependency is redundant.

Version-Release number of selected component (if applicable):
cvs-1.11.21-3.2

How reproducible:
Always

Steps to Reproduce:
1. rpm -q --requires cvs
  
Actual results:
/bin/csh is listed

Expected results:
/bin/cvs is not listed

Additional info:
The only reason for this redundant dependency is the contrib script
/usr/share/cvs/contrib/sccs2rcs. Since the README for contrib scripts says

... BUT, we must point out that these
contributions are really, REALLY UNSUPPORTED.  In fact, we probably
don't even know what some of them really do.  We certainly do not
guarantee to have tried them, or ported them to work with this CVS
distribution. ...

they should not cause hard dependencies.  Maybe they should not be executable at
all (which would simply solve the dependency problems).

Comment 1 Martin Stransky 2006-04-12 11:41:01 UTC
These dependencies are generated by our build system so the only way to remove
it is to remove this script...hard to say what's better


Note You need to log in before you can comment on or make changes to this bug.