Bug 188431 - snd_powermac does not find soundcard / no sound
snd_powermac does not find soundcard / no sound
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
: 189481 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-09 14:11 EDT by Ralf Ertzinger
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-24 13:23:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Ertzinger 2006-04-09 14:11:06 EDT
Description of problem:
The snd_powermac driver does not detect the sound card anymore. The driver is
being loaded during system startup, but alsa claims no devices found:

[sun@lain ~ (0) 19]$ /sbin/lsmod |grep snd
snd_powermac           53964  0 
snd_seq_dummy           4100  0 
snd_seq_oss            42420  0 
snd_seq_midi_event      8672  1 snd_seq_oss
snd_seq                66720  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device         10284  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            51344  0 
snd_mixer_oss          22496  1 snd_pcm_oss
snd_pcm               103268  2 snd_powermac,snd_pcm_oss
snd_timer              29284  2 snd_seq,snd_pcm
snd                    72596  8
snd_powermac,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore              11652  1 snd
snd_page_alloc         11592  1 snd_pcm
[sun@lain ~ (0) 20]$ cat /proc/asound/cards 
--- no soundcards ---
[sun@lain ~ (0) 21]$ cat /proc/cpuinfo 
processor       : 0
cpu             : 750CXe
temperature     : 1 C (uncalibrated)
clock           : 499.999000MHz
revision        : 34.21 (pvr 0008 2215)
bogomips        : 33.15
timebase        : 16640000
platform        : PowerMac
machine         : PowerBook4,1
motherboard     : PowerBook4,1 MacRISC2 MacRISC Power Macintosh
detected as     : 257 (iBook 2)
pmac flags      : 0000001b
L2 cache        : 256K unified
pmac-generation : NewWorld

Version-Release number of selected component (if applicable):
kernel-2.6.16-1.2122_FC6

How reproducible:
always

Steps to Reproduce:
1. boot
2. cat /proc/asound/cards
3.
  
Actual results:
No sound cards found

Expected results:
powermac built in sound card found by driver

Additional info:
kernel-2.6.15-1.2054_FC5 detects the sound card.
Comment 1 Frank Arnold 2006-04-21 02:54:18 EDT
*** Bug 189481 has been marked as a duplicate of this bug. ***
Comment 2 Frank Arnold 2006-04-21 03:00:28 EDT
Hopefully, this will be fixed in the next days:
http://ozlabs.org/pipermail/linuxppc-dev/2006-April/022195.html

(at least devel for the moment)
Comment 3 Ralf Ertzinger 2006-04-24 13:23:09 EDT
Fixed in kernel-2.6.16-1.2153_FC6
Comment 4 Joseph Sacco 2006-04-24 13:28:47 EDT
Tested today.  Works fine.

Thanks,

-Joseph

Note You need to log in before you can comment on or make changes to this bug.