Bug 188434 - Divide error in snd_pcm_oss_ioctl
Divide error in snd_pcm_oss_ioctl
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-09 17:24 EDT by Tom London
Modified: 2015-01-04 17:26 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-23 00:05:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom London 2006-04-09 17:24:03 EDT
Description of problem:
Running latest Rawhide (kernel-2.6.16-1.2122_FC6), I got the following:

Apr  9 13:54:01 localhost kernel: divide error: 0000 [#1]
Apr  9 13:54:01 localhost kernel: last sysfs file:
/devices/system/cpu/cpu0/cpufreq/scaling_cur_freq
Apr  9 13:54:01 localhost kernel: Modules linked in: hfsplus usb_storage usblp
i915 drm ipv6 autofs4 vmnet(U) vmmon(U) ip_conntrack_netbios_ns ipt_REJECT
xt_state ip_conntrack nfnetlink xt_tcpudp iptable_filter ip_tables x_tables
video ibm_acpi button battery ac lp parport_pc parport ehci_hcd uhci_hcd sg
ipw2200 ieee80211 ieee80211_crypt sdhci mmc_core snd_intel8x0m tg3 snd_intel8x0
snd_ac97_codec snd_ac97_bus snd_seq_dummy snd_seq_oss snd_seq_midi_event snd_seq
snd_seq_device snd_pcm_oss snd_mixer_oss snd_pcm i2c_i801 i2c_core snd_timer snd
soundcore snd_page_alloc dm_snapshot dm_zero dm_mirror dm_mod ext3 jbd ahci
ata_piix libata sd_mod scsi_mod
Apr  9 13:54:01 localhost kernel: CPU:    0
Apr  9 13:54:01 localhost kernel: EIP:    0060:[<f8c72084>]    Tainted: P      VLI
Apr  9 13:54:01 localhost kernel: EFLAGS: 00210246   (2.6.16-1.2122_FC6 #1)
Apr  9 13:54:01 localhost kernel: EIP is at snd_pcm_oss_ioctl+0x6be/0x9be
[snd_pcm_oss]
Apr  9 13:54:01 localhost kernel: eax: 00000000   ebx: bfd6b520   ecx: 00000000
  edx: 00000000
Apr  9 13:54:01 localhost kernel: esi: 00000000   edi: d5cd0f20   ebp: 00000000
  esp: f1517f38
Apr  9 13:54:01 localhost kernel: ds: 007b   es: 007b   ss: 0068
Apr  9 13:54:01 localhost kernel: Process realplay.bin (pid: 5605,
threadinfo=f1517000 task=d7cf8030)
Apr  9 13:54:01 localhost kernel: Stack: <0>f1517f58 c04aae35 f757f82c f151807c
00000001 d7cf8030 00000010 00000000
Apr  9 13:54:01 localhost kernel:        00000000 00004000 f6501530 f8c719c6
bfd6b520 00000006 c0468f4d 00000000
Apr  9 13:54:01 localhost kernel:        f6501530 bfd6b520 c0469180 00000000
00000000 00000000 00000000 f6501530
Apr  9 13:54:01 localhost kernel: Call Trace:
Apr  9 13:54:01 localhost kernel:  <c04aae35> file_has_perm+0x89/0x91  
<f8c719c6> snd_pcm_oss_ioctl+0x0/0x9be [snd_pcm_oss]
Apr  9 13:54:02 localhost kernel:  <c0468f4d> do_ioctl+0x19/0x4d   <c0469180>
vfs_ioctl+0x1ff/0x216
Apr  9 13:54:02 localhost kernel:  <c04691e3> sys_ioctl+0x4c/0x65   <c0402c6f>
syscall_call+0x7/0xb
Apr  9 13:54:02 localhost kernel: Code: 94 d2 ff ff 8b b7 6c 02 00 00 89 c2 85
d2 89 d0 0f 88 0d 03 00 00 8b 54 24 24 8b 44 24 08 e8 ba cf ff ff 31 d2 01 f0 89
44 24 20 <f7> b7 4c 02 00 00 89 44 24 14 8d 54 24 14 b9 10 00 00 00 e9 22


Version-Release number of selected component (if applicable):
kernel-2.6.16-1.2122_FC6


How reproducible:
Only happened once.


Steps to Reproduce:
1. run realplay (?)
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tom London 2006-04-09 17:54:03 EDT
Hmmm... just a little bit later I get:

Apr  9 14:58:17 localhost kernel:  <7>application firefox-bin uses obsolete OSS
audio interface
Apr  9 14:58:17 localhost kernel: BUG: unable to handle kernel NULL pointer
dereference at virtual address 00000230
Apr  9 14:58:17 localhost kernel:  printing eip:
Apr  9 14:58:17 localhost kernel: f8c71f9e
Apr  9 14:58:17 localhost kernel: *pde = 3d4c0067
Apr  9 14:58:17 localhost kernel: Oops: 0000 [#2]
Apr  9 14:58:17 localhost kernel: last sysfs file: /class/net/eth0/carrier
Apr  9 14:58:17 localhost kernel: Modules linked in: hfsplus usb_storage usblp
i915 drm ipv6 autofs4 vmnet(U) vmmon(U) ip_conntrack_netbios_ns ipt_REJECT
xt_state ip_conntrack nfnetlink xt_tcpudp iptable_filter ip_tables x_tables
video ibm_acpi button battery ac lp parport_pc parport ehci_hcd uhci_hcd sg
ipw2200 ieee80211 ieee80211_crypt sdhci mmc_core snd_intel8x0m tg3 snd_intel8x0
snd_ac97_codec snd_ac97_bus snd_seq_dummy snd_seq_oss snd_seq_midi_event snd_seq
snd_seq_device snd_pcm_oss snd_mixer_oss snd_pcm i2c_i801 i2c_core snd_timer snd
soundcore snd_page_alloc dm_snapshot dm_zero dm_mirror dm_mod ext3 jbd ahci
ata_piix libata sd_mod scsi_mod
Apr  9 14:58:17 localhost kernel: CPU:    0
Apr  9 14:58:17 localhost kernel: EIP:    0060:[<f8c71f9e>]    Tainted: P      VLI
Apr  9 14:58:17 localhost kernel: EFLAGS: 00210282   (2.6.16-1.2122_FC6 #1)
Apr  9 14:58:17 localhost kernel: EIP is at snd_pcm_oss_ioctl+0x5d8/0x9be
[snd_pcm_oss]
Apr  9 14:58:17 localhost kernel: eax: 00000000   ebx: bff60460   ecx: 00000050
  edx: 8010500c
Apr  9 14:58:17 localhost kernel: esi: f757f82c   edi: 00000000   ebp: 00000000
  esp: d63f5f38
Apr  9 14:58:17 localhost kernel: ds: 007b   es: 007b   ss: 0068
Apr  9 14:58:17 localhost kernel: Process realplay.bin (pid: 6759,
threadinfo=d63f5000 task=cfe3d560)
Apr  9 14:58:17 localhost kernel: Stack: <0>d63f5f58 c04aae35 f757f82c ea7a213c
00000001 cfe3d560 e48646f0 f7176ce4
Apr  9 14:58:17 localhost kernel:        00000001 00000000 f65017e0 f8c719c6
bff60460 00000006 c0468f4d 00000000
Apr  9 14:58:17 localhost kernel:        f65017e0 bff60460 c0469180 00000000
00000000 00000000 00000000 f65017e0
Apr  9 14:58:17 localhost kernel: Call Trace:
Apr  9 14:58:17 localhost kernel:  <c04aae35> file_has_perm+0x89/0x91  
<f8c719c6> snd_pcm_oss_ioctl+0x0/0x9be [snd_pcm_oss]
Apr  9 14:58:17 localhost kernel:  <c0468f4d> do_ioctl+0x19/0x4d   <c0469180>
vfs_ioctl+0x1ff/0x216
Apr  9 14:58:17 localhost kernel:  <c04691e3> sys_ioctl+0x4c/0x65   <c0402c6f>
syscall_call+0x7/0xb
Apr  9 14:58:17 localhost kernel: Code: e9 04 04 00 00 85 db 0f 84 ee 03 00 00
81 fa 0d 50 10 80 0f 94 c0 0f b6 e8 8b 34 ae 85 f6 89 74 24 08 0f 84 c8 03 00 00
8b 7e 5c <f6> 87 30 02 00 00 01 74 0f 89 f0 e8 d7 e2 ff ff 85 c0 0f 88 c6
Comment 2 Tom London 2006-04-13 11:27:40 EDT
This seems to occur every time when gaim generates an alert sound while I have a
skype session running.

Here's the latest 'dump' (kernel-2.6.16-1.2128_FC6):

Apr 13 07:53:25 localhost kernel: divide error: 0000 [#1]
Apr 13 07:53:25 localhost kernel: SMP
Apr 13 07:53:25 localhost kernel: last sysfs file:
/devices/system/cpu/cpu0/cpufreq/scaling_cur_freq
Apr 13 07:53:25 localhost kernel: Modules linked in: ppdev i915 drm ipv6 autofs4
vmnet(U) vmmon(U) ip_conntrack_netbios_ns ipt_REJECT xt_state ip_conntrack
nfnetlink xt_tcpudp iptable_filter ip_tables x_tables video ibm_acpi button
battery ac lp parport_pc parport usblp ehci_hcd sg uhci_hcd ipw2200 sdhci
ieee80211 ieee80211_crypt mmc_core tg3 i2c_i801 snd_intel8x0 snd_intel8x0m
i2c_core snd_ac97_codec snd_ac97_bus snd_seq_dummy snd_seq_oss
snd_seq_midi_event snd_seq snd_seq_device snd_pcm_oss snd_mixer_oss snd_pcm
snd_timer snd soundcore snd_page_alloc dm_snapshot dm_zero dm_mirror dm_mod ext3
jbd ahci ata_piix libata sd_mod scsi_mod
Apr 13 07:53:25 localhost kernel: CPU:    0
Apr 13 07:53:25 localhost kernel: EIP:    0060:[<f8d120d2>]    Tainted: P      VLI
Apr 13 07:53:25 localhost kernel: EFLAGS: 00210246   (2.6.16-1.2128_FC6 #1)
Apr 13 07:53:25 localhost kernel: EIP is at snd_pcm_oss_ioctl+0x6be/0x9c0
[snd_pcm_oss]
Apr 13 07:53:25 localhost kernel: eax: 00000000   ebx: b6f2a440   ecx: 00000000
  edx: 00000000
Apr 13 07:53:25 localhost kernel: esi: 00000000   edi: f12fb1ac   ebp: 00000000
  esp: c5a5ef34
Apr 13 07:53:25 localhost kernel: ds: 007b   es: 007b   ss: 0068
Apr 13 07:53:25 localhost kernel: Process skype (pid: 11441, threadinfo=c5a5e000
task=dfb65ab0)
Apr 13 07:53:25 localhost kernel: Stack: <0>c5a5ef90 c5a5ef58 f6c5aa44 c5a5ef58
f109e488 00000001 00000010 00000000
Apr 13 07:53:26 localhost kernel:        00000000 00004000 f8d11a14 f13c5128
b6f2a440 8010500c c0476f13 00000000
Apr 13 07:53:26 localhost kernel:        00000000 f13c5128 b6f2a440 0000001e
c04771a0 00000000 00000000 00000000
Apr 13 07:53:26 localhost kernel: Call Trace:
Apr 13 07:53:26 localhost kernel:  <f8d11a14> snd_pcm_oss_ioctl+0x0/0x9c0
[snd_pcm_oss]   <c0476f13> do_ioctl+0x1f/0x62
Apr 13 07:53:26 localhost kernel:  <c04771a0> vfs_ioctl+0x24a/0x25c   <c04771fe>
sys_ioctl+0x4c/0x66
Apr 13 07:53:26 localhost kernel:  <c0403de7> syscall_call+0x7/0xb
Apr 13 07:53:26 localhost kernel: Code: 46 d2 ff ff 8b b7 6c 02 00 00 89 c2 85
d2 89 d0 0f 88 0d 03 00 00 8b 54 24 24 8b 44 24 08 e8 6c cf ff ff 31 d2 01 f0 89
44 24 20 <f7> b7 4c 02 00 00 89 44 24 14 8d 54 24 14 b9 10 00 00 00 e9 22
Comment 3 Tom London 2006-04-18 10:51:35 EDT
Hmm... I cannot reproduce with kernel-2.6.16-1.2134_FC6

Did something get fixed?  Don't see anything in changelog.
Comment 4 Dave Jones 2006-06-23 00:05:31 EDT
reopen if it reoccurs.

Note You need to log in before you can comment on or make changes to this bug.