Bug 1884340 - Fedora 33 beta hangs on “Started GNOME Display Manager” in VirtualBox
Summary: Fedora 33 beta hangs on “Started GNOME Display Manager” in VirtualBox
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-session
Version: 33
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-01 17:59 UTC by AM
Modified: 2020-10-02 02:59 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: ---
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-02 02:59:05 UTC
Type: Bug


Attachments (Terms of Use)

Description AM 2020-10-01 17:59:57 UTC
Description of problem:
When booting the .iso of F33 in VirtualBox, I can get through the process until “Started GNOME Display Manager” appears, and then it hangs. It will boot in VMWare and on actual hardware.

Version-Release number of selected component (if applicable):
Fedora 33 beta 1.3
VirtualBox 6.1.14

How reproducible:
Always

Steps to Reproduce:
1. Create a VM in VirtualBox
2. Boot from the .iso image of Fedora 33 beta
3. Wait through the process until “Started GNOME Display Manager” appears

Actual results:
The boot process hangs.

Expected results:
The desktop should appear.

Additional info:
On VirtualBox on Mac it completely aborts the VM once it gets to the same point. On Windows it just gets stuck.

I can’t access a tty terminal and removing “quiet” from the boot options doesn’t show anything extra before it hangs.

Comment 1 AM 2020-10-01 23:52:58 UTC
I can boot Fedora 33 successfully using VirtualBox 6.1.15 r140270 (Qt5.6.1) on Fedora 32.

Comment 2 AM 2020-10-02 00:06:52 UTC
Also it works on Windows now too... hm. I'm running Big Sur on the Mac, so I can overlook that bug. Haven't tried Catalina yet but I assume it works. This is likely just a coincidental incompatibility that looks like something else. Will report back shortly.

Comment 3 AM 2020-10-02 02:59:05 UTC
It works on Catalina (although the bootup text flashes, using 6.1.6 I think) so I'm chalking this up to something with VirtualBox and/or Big Sur rather than Fedora.

As for the Windows case, I updated VirtualBox and it didn't fix it, but after restarting I was able to boot F33 successfully.


Note You need to log in before you can comment on or make changes to this bug.