Bug 188456 - preedit should do word-wrap for too long preedit line
preedit should do word-wrap for too long preedit line
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: vte (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
: FutureFeature, i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-10 04:08 EDT by Akira TAGOH
Modified: 2009-03-25 23:15 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-25 23:15:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Akira TAGOH 2006-04-10 04:08:04 EDT
Description of problem:
SSIA

Version-Release number of selected component (if applicable):
1.4.4-12

How reproducible:
always

Steps to Reproduce:
1.input something over the window size in preedit
2.
3.
  
Actual results:
preedit line is horizontally scrolled first and finally cursor is out of window
then.

Expected results:
preedit line should be just word-wrap'ed.

Additional info:
Comment 1 Hu Zheng 2007-01-30 22:37:00 EST
I can't reproduce this bug in FC6.
The effect of wrap in preedit just like the effect as normal input. If the
string contain Non-English characters or Space, it will wrap.
This should be a old gtk bug, can you reproduce it with the new gtk version?
Comment 2 Akira TAGOH 2007-01-30 23:30:58 EST
Well, this issue is still reproducible on gnome-terminal. reassigning to vte then.
Comment 3 Tony Fu 2008-09-09 23:11:34 EDT
requested by Jens Petersen (#27995)
Comment 4 Behdad Esfahbod 2009-03-25 23:15:15 EDT
http://bugzilla.gnome.org/show_bug.cgi?id=329559

Note You need to log in before you can comment on or make changes to this bug.