Bug 188471 - SWTException: Invalid thread access during Eclipse startup
SWTException: Invalid thread access during Eclipse startup
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ben Konrath
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-10 09:35 EDT by Anthony Green
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-02 23:00:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Eclipse log file. (18.57 KB, text/plain)
2006-04-10 09:35 EDT, Anthony Green
no flags Details

  None (edit)
Description Anthony Green 2006-04-10 09:35:07 EDT
Description of problem:

JVM aborts during startup.  I'll attach the full log file.  The root cause of
the abort is:

Caused by: org.eclipse.swt.SWTException: Invalid thread access
   at org.eclipse.swt.SWT.error (org.eclipse.swt.gtk.linux.x86_3.1.1.jar.so)
   at org.eclipse.swt.SWT.error (org.eclipse.swt.gtk.linux.x86_3.1.1.jar.so)
   at org.eclipse.swt.SWT.error (org.eclipse.swt.gtk.linux.x86_3.1.1.jar.so)
   at org.eclipse.swt.widgets.Display.error
(org.eclipse.swt.gtk.linux.x86_3.1.1.jar.so)
   at org.eclipse.swt.widgets.Display.checkDevice
(org.eclipse.swt.gtk.linux.x86_3.1.1.jar.so)
   at org.eclipse.swt.widgets.Display.getSystemFont
(org.eclipse.swt.gtk.linux.x86_3.1.1.jar.so)
   at org.eclipse.jface.preference.PreferenceConverter.<clinit>
(org.eclipse.jface_3.1.1.jar.so)
   at java.lang.Class.initializeClass (libgcj.so.7)


Version-Release number of selected component (if applicable):
eclipse-platform-3.1.2-1jpp_13fc
libgcj-4.1.0-3
java-1.4.2-gcj-compat-1.4.2.0-40jpp_83rh


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Anthony Green 2006-04-10 09:35:07 EDT
Created attachment 127546 [details]
Eclipse log file.
Comment 2 Anthony Green 2006-06-02 23:00:25 EDT
I can't reproduce this.  Both gcc and eclipse have since been updated.  Maybe
that fixed the problem.  I'm going to close this.

Note You need to log in before you can comment on or make changes to this bug.