Bug 188513 - init 9 also works
init 9 also works
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: sysvinit (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-10 16:03 EDT by acount closed by user
Modified: 2014-03-16 22:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-10 16:11:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description acount closed by user 2006-04-10 16:03:13 EDT
/sbin/init may work only with "0123456Ss" but '9' also works and it's not
defined at /etc/inittab

# init 9
Comment 1 Bill Nottingham 2006-04-10 16:11:47 EDT
init supports 0-9 and the special letter runlevels, we just don't define 7/8/9.
Comment 2 acount closed by user 2006-04-11 13:40:51 EDT
> init supports 0-9 and the special letter runlevels, we just don't define 7/8/9.

but # init 9 "works" . And the system is left in a _catatonic_ state. Did you
try it ?
Comment 3 Bill Nottingham 2006-04-11 14:15:28 EDT
It's doing what is (more or less) expected - it's switching to a runlevel with
no processes to run, so it kills everything.

As mentioned in the man page:

       Runlevels  7-9  are  also  valid, though not really documented. This is
       because "traditional" Unix variants don’t use  them. 

Since this requires root access to do, it's not really a big issue, AFAICT.
Comment 4 David Lawrence 2007-06-21 22:18:07 EDT
Package name is now sysvinit in latest Fedora.

Note You need to log in before you can comment on or make changes to this bug.