Bug 188540 - No sound with Intel HDA/ALC260
No sound with Intel HDA/ALC260
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-10 20:35 EDT by John Straw
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-23 14:47:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of system-config-soundcard after upgrading ALSA drivers to 1.0.11-rc4 (7.63 KB, text/plain)
2006-04-10 20:35 EDT, John Straw
no flags Details
Output of system-config-soundcard with default kernel drivers (7.54 KB, application/octet-stream)
2006-04-10 20:38 EDT, John Straw
no flags Details

  None (edit)
Description John Straw 2006-04-10 20:35:38 EDT
Sound worked with this hardware in Fedora Core 4.  After an upgrade to Fedora
Core 5, sound did not work.  Currently, sound does not work on this machine with
either kernel-smp-2.6.15-1.2054_FC5 or kernel-smp-2.6.16-1.2080_FC5.

I have gone through the normal steps of running system-config-soundcard and
using alsamixer to make sure that output channels are not muted.  No sound.

The proper sound modules seem to be loaded but the sound device doesn't appear
to get initialized properly.  For example, 'cat
/sys/module/snd_hda_intel/parameters/model' returns "<NULL>", which I gather
from some reading around means that the module hasn't loaded and/or initialized
the device correctly.

This issue seems similar to that discussed in bug #182940, but I've not been
able to find any reference to the ALC260 in any of the discussion of this issue
(that bug is for the HDA/STAC92xx).  My computer is not a laptop, either, but an
HP desktop.

My problem may be related to the issues described in
https://bugtrack.alsa-project.org/alsa-bug/view.php?id=1843.  However, the
changes made to ALSA drivers for 1.0.11-rc4 do not fix the problem for me.  I
upgraded my ALSA drivers to 1.0.11-rc4 by following the instructions in
http://people.redhat.com/stransky/alsa/ with no change.
Comment 1 John Straw 2006-04-10 20:35:38 EDT
Created attachment 127581 [details]
Output of system-config-soundcard after upgrading ALSA drivers to 1.0.11-rc4
Comment 2 John Straw 2006-04-10 20:38:29 EDT
Created attachment 127582 [details]
Output of system-config-soundcard with default kernel drivers
Comment 3 German 2006-06-20 12:42:48 EDT
I have a HP dc7600 with kernel-smp-2.6.16-1.2080_FC5, and had exactly
the same problem. I've installed the latest alsa drivers and still no
sound at all. 

Finally I succeded by adding the line

  options snd-hda-intel model=basic

to file /etc/modprobe.conf (then reboot and unmute the volume with
alsamixer)

good luck!
Comment 4 John Straw 2006-06-21 14:26:04 EDT
Yes, adding the model parameter works for me, too.  Also, there's a patch at
https://bugtrack.alsa-project.org/alsa-bug/view.php?id=2106 which solves the
problem for me, as well.
Comment 5 John W. Linville 2006-06-23 14:47:20 EDT
Cool...thanks for the info!

Note You need to log in before you can comment on or make changes to this bug.