Bug 188541 - Fast user switching doesn't work
Fast user switching doesn't work
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-screensaver (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-10 20:43 EDT by David Kaplan
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-20 16:58:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Kaplan 2006-04-10 20:43:30 EDT
Description of problem:
When I activate user switching in gconf and then lock the screen,
gnome-screensaver allows me to pick a user to switch to, but then does nothing
and returns me to the locked screen - i.e. I never get the chance to login as
the other user.

Version-Release number of selected component (if applicable):
gnome-screensaver-2.14.0-1.fc5.1

How reproducible:
Always

Steps to Reproduce:
1.enable user_switch_enabled in gconf
2.lock screen
3.Click of "switch user" on the lock dialogue
4.Select user to switch to and click "switch user"
  
Actual results:
Nothing happens - screen is still locked as original user

Expected results:
Ask for password for new user and switch to that user.

Additional info:
Comment 1 David Kaplan 2006-05-24 03:42:21 EDT
I see that a couple people are CC'ed on this.  Are you experiencing the same
problems?  More comments would help get a response on this.

Comment 2 Calvin Smith 2006-05-25 16:07:42 EDT
I'm seeing a similar problem, but only with the default fedora bubbles
screensaver. If I choose a different screensaver that has the default
screensaver it works fine. 

What happens is that the if I enable the user_switch_enabled flag, the lock
dialogue box never comes up and I would have to switch to a different vt in
order to get it to work. 
Comment 3 Pedro Lamarão 2006-06-06 19:57:50 EDT
Is this a duplicate of bug #190339?
Comment 4 David Kaplan 2006-06-06 20:12:31 EDT
The behavior they describe is different from mine, but perhaps it is related.
Comment 5 Stefan Plewako 2006-06-07 04:53:21 EDT
Hi! After the today's big update I checked it and it works.
But one is strange for me: after how I am choosing which user I want to change
to, I am getting the standard screen of logging on, after choosing the user for
the second time and giving the password logging on is taking place. Then all
goes right. Later (evening, I hope) I will try to check whether it is not a
fault of my conf.
Comment 6 Pedro Lamarão 2006-06-07 08:27:06 EDT
After today's big Fedora Core 5 update, or Rawhide update?
Comment 7 Pedro Lamarão 2006-06-07 09:35:14 EDT
I confirmed Comment #5 above in an up to date Fedora Core 5 system.
This seems to be the currently intended behaviour: the "Switch user..." thing
appears to be actually spawning a nested X server.
Comment 8 Stefan Plewako 2006-06-07 13:32:52 EDT
(In reply to comment #6)
> After today's big Fedora Core 5 update, or Rawhide update?

FC5 stable, with repos: core, core-update, extras & livna
Comment 9 Alex Lancaster 2006-06-14 01:56:58 EDT
With the latest updates (2006-06-12) and gnome-screensaver-2.14.2-1, I still get
the same problem as described in comment #0.  When I run gnome-screensaver from
the command-line, I see:

(gnome-screensaver-dialog:1835): Screensaver-Fast-User-Switch-CRITICAL **: Could
not parse GDM configuration file `/etc/X11/gdm/gdm.conf': No such file or directory

which is the same kind of error as in bug #190339.
Comment 10 Alex Lancaster 2006-06-22 09:46:13 EDT
User switching (from the gnome-screenaver locking screen) works for me now with
gdm-2.14.9-1 just pushed to FC-5 updates.  Looks like it might have been a gdm
problem.
Comment 11 Ray Strode [halfline] 2007-08-20 16:58:03 EDT
This problem got resolved some time ago.

Note You need to log in before you can comment on or make changes to this bug.