This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 188557 - Kernel panic on kernel load during installation
Kernel panic on kernel load during installation
Status: CLOSED DUPLICATE of bug 162977
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Jim Paradis
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-11 02:29 EDT by allance
Modified: 2013-08-05 21:18 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-28 19:44:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Failure screenshot (128.41 KB, image/jpeg)
2006-04-11 02:29 EDT, allance
no flags Details

  None (edit)
Description allance 2006-04-11 02:29:02 EDT
Description of problem:
Install RHEL AS4 U3 64bit with more than 4G memory size.When system boot from 
OS installation CD1, then "Kernel Panic" occurs on kernel load.
The message is “Kernel Panic-not syncing" PCI-DMA: high address but no IOMMU.”
There is a workaround to add "pic=nommconf" to disable MCFG table in 
installation option menu.
Only happen on RH4, RH3 is ok.

Version-Release number of selected component (if applicable):


How reproducible:
1.Boot from installation CD1.
2.In install main menu, Press “enter” to start installation.
3."Kernel Panic - not syncing: PCI-DMA: high address but no IOMMU" message pop 
up.

Steps to Reproduce:
1.Boot from installation CD1.
2.In install main menu, Press “enter” to start installation.
3."Kernel Panic - not syncing: PCI-DMA: high address but no IOMMU" message pop 
up.

  
Actual results:


Expected results:
Hope this can be fixed in next build.

Additional info:
Comment 1 allance 2006-04-11 02:29:02 EDT
Created attachment 127594 [details]
Failure screenshot
Comment 2 Anil S Keshavamurthy 2006-05-08 18:43:17 EDT
Are you sure you are seeing this on IA64 and not on x86_64. The reason is that I
did not see the panic("PCI-DMA: high address but no IOMMU.\n"); statement in
arch/ia64 directory. However I saw this the above statement in
arch/x86_64/kernel/pci-gart.c. 
Can you verify this and change the bug to appropriate architecture.
Comment 3 allance 2006-05-08 20:51:25 EDT
Sorry for mistake. I have changed the architecture to x86_64
Comment 4 Dan Carpenter 2006-05-08 22:52:58 EDT
What's the motherboard and which CPUs are you using?

Comment 5 allance 2006-05-08 23:09:13 EDT
It designed with nVidia MCP55P SB and AMD Opetron Dual core Socket F 
processor. It doesn't matter what cpu speed is. 
Comment 6 Jim Paradis 2006-06-22 14:38:41 EDT
Have you tried the latest RHEL4 U4 kernel on this configuration?  I have the
feeling this *might* be related to Bug 162977, which is fixed in the latest beta.
Comment 7 Jim Paradis 2006-09-28 19:44:30 EDT
Closing as dup of 162977

*** This bug has been marked as a duplicate of 162977 ***

Note You need to log in before you can comment on or make changes to this bug.