Bug 188577 - Apache::RequestRec in RHEL3 does not work
Summary: Apache::RequestRec in RHEL3 does not work
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: mod_perl   
(Show other bugs)
Version: 3.0
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Joe Orton
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-04-11 13:31 UTC by John C. Checco, CISSP
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 18:45:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John C. Checco, CISSP 2006-04-11 13:31:29 UTC
Description of problem:


Version-Release number of selected component (if applicable):
- kernel-smp-2.4.21-32.0.1.EL
- httpd-2.0.46-56.ent
- mod_perl-1.99_09-10.ent

How reproducible:
obtain Apache::AuthDBI and configure a single directory to use it... the apache
error log will return the following:
1) Can't locate object method "is_initial_req" via package "Apache::RequestRec"
2) Can't locate object method "dir_config" via package "Apache::RequestRec"
or
3) Can't locate Apache/Constants.pm in @INC  

item #3 was caused by mod_perl 1.99 version using Apache::AuthDBI earlier 1.x
constants, but once code was forces to use mod_perl 2.x Apache::Const module,
the above errors #1/#2 still occurred, which means the apreq libraries for
httpd-2.0.46 are not working.

Additional info:
Although I am trying to stay away from compiling/installing packages outside
RHEL3 base, I tried compiling latest mod_perl-2.0.2, but it needs httpd >=
2.0.56 (which RHEL3 does not provide)

Comment 1 RHEL Product and Program Management 2007-10-19 18:45:23 UTC
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.


Note You need to log in before you can comment on or make changes to this bug.