Bug 188603 - Patch to fix playlist randomize
Summary: Patch to fix playlist randomize
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xmms   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ville Skyttä
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-04-11 17:28 UTC by David Cantrell
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 1.2.10-29
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-06 21:20:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xmms randomize fix (1.42 KB, patch)
2006-04-11 17:28 UTC, David Cantrell
no flags Details | Diff

Description David Cantrell 2006-04-11 17:28:47 UTC
Well known problem.  XMMS sucks at randomizing large playlists.  Attached is a
patch from David Shea of the more-or-less dormant Peachtree Linux project.  It
corrects the randomization problem in xmms so it doesn't cycle through the same
4 or 5 songs.

Comment 1 David Cantrell 2006-04-11 17:28:47 UTC
Created attachment 127625 [details]
xmms randomize fix

Comment 2 Ville Skyttä 2006-10-04 18:03:24 UTC
Reassigning to current xmms maintainer (myself - haven't seen this bug report 
before now).

Comment 3 Ville Skyttä 2006-10-19 20:48:14 UTC
Upstream CVS appears to have similar changes, see 
http://cvs.xmms.org/cvsweb.cgi/xmms/xmms/playlist.c.diff?r1=1.88&r2=1.89 and 
the last hunk of 
http://cvs.xmms.org/cvsweb.cgi/xmms/xmms/playlist.c.diff?r1=1.84&r2=1.85

Could you check if they work for you?

Comment 4 David Cantrell 2006-10-23 15:32:41 UTC
I've long since stopped using xmms in Fedora now, but looking at the upstream
code, it appears that they've finally fixed that problem.

Comment 5 Ville Skyttä 2006-11-06 21:20:08 UTC
Upstream changes applied in 1.2.10-29.fc*


Note You need to log in before you can comment on or make changes to this bug.